(newbie)Troubles with SE-Linux

Paul Rumin purenrg7 at gmail.com
Tue Mar 22 00:48:37 UTC 2005

I would like to preface this with "I am not new to linux,  but new to
SE-Linux."  I am not sure where to begin with this problem.  After a
clean install of Fedore Core 3 (at least I thought clean),  I tried to
login in with a user account a few days later.  This did not work,  so
I logged in as root to change my user's password.

1. First,  I tried changing the user's password with passwd. Although
the program seemed to accept the new password.  I still was unable to
login in afterwards.

2. So I tried to manually change it within the /etc/passwd file. 
Knowing that there was a shadow file,  I deleted the encrypted
password in shadow and the "x" in the /etc/password file. Then, I ran
passwd, followed by pwconv.  But still nothing.

3. Finally,  I tried to just use "su" command into my user's account
to no avail.

Now I am stuck.  My understanding of SE is that you must match
securities contents of the files,  by using the -Z delimiter, which I
did verify.

If someone could steer me in the right direction I would appreciate it.


BTW, I did also try userdel/useradd with no success.

More information about the fedora-selinux-list mailing list