[newbie] YUM hangs, can't update without reboot with selinux=0

Colin Walters walters at redhat.com
Tue Mar 22 20:40:15 UTC 2005

On Tue, 2005-03-22 at 15:27 -0500, John Johnson wrote:
> Hash: SHA1
> On 21-Mar-2005, at 09:52, Colin Walters wrote:
> > On Mon, 2005-03-21 at 09:31 -0500, John Johnson wrote:
> >
> >> When I run YUM, it runs briefly, then just sits there. Even when I do
> >
> > And if you do a 'touch /.autorelabel; reboot' and do *not* pass
> > selinux=0, then yum hangs again?
> >
> That worked Colin, thanks!
> Even up2date works now. Maybe I'll find out why after learning more 
> about SE.

Again, I don't think your problem related to SELinux at all.  

My suggested command should have essentially just restored your system
to its state before you booted with selinux=0.

In the future, I'd suggest trying other solutions before rebooting with
selinux=0, particularly if you don't see any "avc: denied" messages in
your system log.

More information about the fedora-selinux-list mailing list