SELinux support in awstats RPM

Aurelien Bompard gauret at
Mon Apr 10 08:36:30 UTC 2006

Yeah, well, it doesn't work.
If I run semanage in %pre, the files in /usr/share/awstats/wwwroot/cgi-bin
are still labelled usr_t.

I've made a separate package, as advised by Stephen in your mail, which runs
semanage in %pre (I tried %post too), and I have the following results :

- If I install both awstats and awstats-selinux at the same time (sudo rpm
  -Uvh noarch/awstats-*.rpm), the files are still usr_t

- If I install them separately, first awstats-selinux and then awstats, the
files are labelled correctly (httpd_sys_script_exec_t)

It looks like some transaction mechanism in RPM is causing the problem here.
Is there a RPM guru here ? Stephen ? Dan ?

What is the correct solution ? Run restorecon in %post ?

Thanks for your help,

--  ~~~~  Jabber : abompard at
"They that can give up essential liberty to obtain a little temporary
safety, deserve neither liberty nor safety." -- Benjamin Franklin

More information about the fedora-selinux-list mailing list