SELinux support in awstats RPM

Paul Howarth paul at
Mon Apr 10 09:32:23 UTC 2006

Aurelien Bompard wrote:
> Yeah, well, it doesn't work.
> If I run semanage in %pre, the files in /usr/share/awstats/wwwroot/cgi-bin
> are still labelled usr_t.
> I've made a separate package, as advised by Stephen in your mail, which runs
> semanage in %pre (I tried %post too), and I have the following results :
> - If I install both awstats and awstats-selinux at the same time (sudo rpm
>   -Uvh noarch/awstats-*.rpm), the files are still usr_t
> - If I install them separately, first awstats-selinux and then awstats, the
> files are labelled correctly (httpd_sys_script_exec_t)
> It looks like some transaction mechanism in RPM is causing the problem here.
> Is there a RPM guru here ? Stephen ? Dan ?
> What is the correct solution ? Run restorecon in %post ?
> Thanks for your help,

When you had separate packages, did you have:

Requires(pre): awstats-selinux
in the main awstats package?


More information about the fedora-selinux-list mailing list