selinux-policy-targeted.noarch 1.27.1-2.28 on fc4 parameters passing problem (2.6.15-1.1833_FC4)

Jin Kee jin.kee at
Fri Apr 28 16:43:36 UTC 2006

Dear All,

Is this the right list for this question?

I just yumed from selinux-policy-targeted.noarch 1.27.1-2.22 to
selinux-policy-targeted.noarch 1.27.1-2.28 last night and now my cgi
scripts in perl can't find the parameters passed to them from forms.

I made a test script which submits a form and then goes print
param('foo') inside the returning html document, but all I see are my
scaffolding lines that tell me that the script has loaded, has
rendered html and then is about to finish.

when I run the same script as root from the command line it prints the
html and the correct value of 'foo'.

Before the update, I had altered my selinux policies to make httpd
listen on a higher port, but that is the only change I made.

#vi /etc/selinux/targeted/src/policy/net_contexts:
portcon tcp 8090  system_u:object_r:http_port_t
# make -C /etc/selinux/targeted/src/policy reload

That's the only change

I'm running
Linux localhost.localdomain 2.6.15-1.1833_FC4 #1 Wed Mar 1 23:41:37
EST 2006 i686 athlon i386 GNU/Linux

This is perl, v5.8.8 built for i686-linux
$CGI::revision = '$Id:,v 1.194 2005/12/06 22:12:56 lstein Exp $';

The perl scripts worked yesterday. Any body else having this problem?


More information about the fedora-selinux-list mailing list