Samba shares...

Daniel B. Thurman dant at
Tue May 13 17:27:58 UTC 2008

Daniel B. Thurman wrote:
|Stephen Smalley
||On Tue, 2008-05-13 at 08:12 -0700, Daniel B. Thurman wrote:
||> Stephen Smalley wrote:
||> >> Daniel B. Thurman wrote:
||> >> I am not sure what is going on.  I am unable to get
||> >> samba shares to work for an NTFS filesystem.  I do
||> >> have several shares working for ext3 filesystems.
||> >> 
||> >> Here is what I did:
||> >> 
||> >> 1) Create an empty directory: /AV
||> >> 2) chcon -t samba_share_t /AV
||> >> 3) chmod 775 !$
||> >> 4) chgrp avusers !$
||> >> 5) Add to fstab
||> >>    /dev/sda1 /AV ntfs defaults 1 2
|   [snipped!]
||It is just another mount option, so you can just do something like:
||/dev/sda1 /AV ntfs 
|defaults,context=system_u:object_r:samba_share_t 1 2
|Yes, I thought so.  I tried that and the context does not
|change.  Any ideas?

Mounting an NTFS filesystem even with context options,
the context always remains as fusefs_t. I am allowed
to change the context on the directory before the mount,
but not after the mount. After mounting, I am not allowed
to chcon the mounted FS as it says that the Operation is
not allowed.

I even tried: setsebool -P samba_export_all_rw=1 and that
does not work, either.

If I setenforce 0, I can share the NTFS filesystem, but I
really do not want to do this.  Can someone please give me
a workaround?


More information about the fedora-selinux-list mailing list