Samba shares...

Daniel B. Thurman dant at
Tue May 13 19:23:35 UTC 2008

Daniel B. Thurman wrote:
|Daniel J Walsh
[ snip! ]
||This looks like a bug.
|Seems so.  Also, I tried disabling the fuse service
|and rebooted and for some reason, the fusefs still
|runs?  It still mounts /media files even when this
|service is so-called disabled?  I went back to look
|to see if the service was running (it wasn't) and
|even tried ps -ef| grep fuse (finding no match), so
|why is fuse filesystem still running?  Is that a major
|bug or is it that the fuse service has no relation to
|the fusefs?
|Well, can I have a policy work around or will it fail
|anyway due to fuse?
|BTW: I am running Fedora F8.

Oh man....

This is what I did:

1) Disable the fuse service permemantly
2) Unmount all fuse filesystems (as root)
3) rmmod fuse
4) lsmod| grep fuse  (make sure fuse module is NOT loaded)
5) mount /dev/sda1 /AV -t ntfs -o context=system_u:object_r:samba_share_t
6) lsmod|grep fuse (module is reloaded!)
7) ls -ldZ /AV  shows fusefs_t context.

So it looks like there is no possible way to get rid of
the fuse filesystem module, mount seems to force a fuse
filesystem regardless of attempts NOT to do so!  Grrr....

Well, please let me know what to do at this point.  Seems
I have to wait or to setenforce 0 for now until this fix
for F8 appears upstream?

Thanks for all your time guys!

More information about the fedora-selinux-list mailing list