[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ImportError: /usr/lib/wxPython/lib/libwx_gtk2ud-2.4.so: undefined symbol: _gtk_accel_group_detach



Hello,
I have been trying to install wx-python on my current installation of Fedora Core 1.9 as I have done it before several times.
using wxPythonSrc-2.4.2.4 i built and installed wxGTK with --enable-gtk2 and --enable-unicode into /usr/lib/wxPython.
Afterwards I built and installed wxPython exactly as described in README.1st


All steps concluded without any errors.

However any try to use wxPython gives the following result:


[sigmund pgrc-22 sigmund]$ python python_scripts/gui/test7.py
Traceback (most recent call last):
File "python_scripts/gui/test7.py", line 16, in ?
from wxPython.wx import *
File "/usr/lib/python2.3/site-packages/wxPython/__init__.py", line 20, in ?
import wxc
ImportError: /usr/lib/wxPython/lib/libwx_gtk2ud-2.4.so: undefined symbol: _gtk_accel_group_detach




here is ldd's output:

[sigmund pgrc-22 sigmund]$ ldd /usr/lib/wxPython/lib/libwx_gtk2ud-2.4.so
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x0034b000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00162000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00111000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00964000)
libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x0012b000)
libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x0082a000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x001d0000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00204000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00130000)
libdl.so.2 => /lib/libdl.so.2 (0x00134000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x0083d000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x0023c000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x002b9000)
libm.so.6 => /lib/tls/libm.so.6 (0x002de000)
libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x00602000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00138000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00301000)
libc.so.6 => /lib/tls/libc.so.6 (0x006bd000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00841000)
libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x00140000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x00143000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00312000)
libXft.so.2 => /usr/X11R6/lib/libXft.so.2 (0x00320000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00978000)
libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x00332000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x007d8000)
libXcursor.so.1 => /usr/X11R6/lib/libXcursor.so.1 (0x0033a000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x0014c000)
libz.so.1 => /usr/lib/libz.so.1 (0x007ff000)
libexpat.so.0 => /usr/lib/libexpat.so.0 (0x00909000)


--------the installed gtk packages are:


rpm -qa | grep gtk pygtk2-2.2.0-1 gtkhtml2-2.5.6-1 gtk+-1.2.10-29.1.1 gtkhtml3-3.0.10-1 gtksourceview-0.9.2-1 gtkhtml2-debuginfo-2.5.6-1 gtksourceview-devel-0.9.2-1 usermode-gtk-1.69-5 gtk-engines-0.12-3.0.1 gtkhtml-devel-1.1.9-7 gtk2-debuginfo-2.4.0-1 gtk+-debuginfo-1.2.10-29.1.1 gtkhtml2-devel-2.5.6-1 pygtk2-libglade-2.2.0-1 gtkspell-2.0.4-4.1 pygtk2-devel-2.2.0-1 gtk-doc-1.2-1 gtk2-engines-2.2.0-5 gtkam-gimp-0.1.10-2.1 gtksourceview-debuginfo-0.9.2-1 gtkam-debuginfo-0.1.10-2.1 gtkhtml3-devel-3.0.10-1 gtk2-2.4.0-1 mtr-gtk-0.54-4 gtkspell-debuginfo-2.0.4-4.1 gtkglarea-1.2.2-19 gtkhtml-debuginfo-1.1.9-7 gtkspell-devel-2.0.4-4.1 gtk2-devel-2.4.0-1 gtk2-engines-debuginfo-2.2.0-5 gtk-engines-debuginfo-0.12-3.0.1 gnome-python2-gtkhtml2-2.0.0-4.1 authconfig-gtk-4.6.1-1.1.1 gtkam-0.1.10-2.1 gtk+-devel-1.2.10-29.1.1 gtkhtml-1.1.9-7 gtkhtml3-debuginfo-3.0.10-1 gtkglarea-debuginfo-1.2.2-19



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]