[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5T1 and Nvidia Driver



Matt Carter wrote:
Hi Guys

Now that I have a "Working" FC5 install I decided to start with adding
the Nvidia Driver to my Kernel, no problems I thought.

Downloaded and started doing the install as normal from console, said
it required the GCC stuff and the Kernel Devel, installed those.
Nvidia installed, great I thought, started editing my Xorg.conf so
that my Geforce Go 6200 TC would be able to use the driver. Changed
driver to "nvidia" as per normal, rebooted and no xserver. So I tried
again and added the extra specifics for my laptop such as the
Modeline. Happened again so this time I put in "nv" instead of "nvidia
and it worked?

Not sure what is going on as X wouldnt output a detailed problem.

Matt

You need to move some files around, or add soft-links. This worked for me:

#!/bin/bash
mkdir -p /usr/lib/xorg/modules/drivers
cd /usr/lib/xorg/modules/drivers
ln -sf /usr/X11R6/lib/modules/drivers/nvidia_drv.so .
ln -sf /usr/X11R6/lib/modules/drivers/nvidia_drv.o .
mkdir -p /usr/lib/xorg/modules/extensions
cd /usr/lib/xorg/modules/extensions
ln -sf /usr/X11R6/lib/modules/extensions/libglx.so .
ln -sf /usr/X11R6/lib/modules/extensions/libglx.so.1.0.7676 .
cd /usr/lib
ln -sf /usr/X11R6/lib/libXvMCNVIDIA.a .
ln -sf /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.7676 .
ln -sf /usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1 .



John


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]