FC5t3 - rpm -e hangs up

Jan Andrejkovic jandrejkovic at gmail.com
Wed Mar 1 02:39:18 UTC 2006


I have upgraded FC4 to FC5t3. I had some xen problems therefore I have
decided to reinstall xen packages.
But when I try
rpm -e kernel-xen-hypervisor-devel or rpm -e kernel-xen-guest-devel rpm
hangs up and eats almost 100% cpu for long time.
I need to use kill -9 to stop it.

I have tried to do
rm -f /var/lib/rpm/__db*
rpm --rebuilddb
but nothing helped after those commands - it hangs again.

I have also tried rpm -e --justdb but it did not help either.

Initially it was "yum remove" which hanged first. But as far as I know it
uses rpm therefore I report this as rpm problem.

Does anybody have the same problem or can anybody tell me some workaround
how I can remove those packages manually and possibly rebuild database
without them?

Thank you very much,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/fedora-test-list/attachments/20060301/724710c1/attachment.htm>

More information about the fedora-test-list mailing list