Problem installing FC5 guest in Xen on FC5 using

Scott D Hankin scott.hankin at
Tue Mar 21 12:44:08 UTC 2006

OK, I finally got it installed.  Perhaps I was trying something you're not
supposed to do.

First of all, the xen0 machine is a VMware image.  This caused a problem I
hadn't forseen - apparently VMware's NAT server is fussy about any machine
other than the one launched asking for an IP address.  There is a NAT
setting ("Allow any OUI") which is off by default that needs to be on before
it will give an address to any of the xenU domains.

Before discovering that, I attempted to set up a DHCP server on xen0.  This
appeared to work, but when I attempted to get an address during
installation, I would get "bad checksum" messages on the packets.  I don't
know why, but I had to abandon that approach.  I'll have to revisit that, as
I'd like to set up xenU domains that can know see and reach each other.

I was trying to install Fedora from the DVD image, which was mounted on the
virtual CD/DVD drive.  Since xenguest/anaconda can only accept NFS/FTP/HTTP
locations, I had to jump through some hoops to get that done.

I first tried setting up vsftpd and using FTP.  That didn't work well -
anaconda crashed badly when it went to get stuff.  So I tried setting up NFS
and explicitly exporting the mount point.  That failed with permission
errors.  Finally I set up httpd to contain a link to the mounted image in
the default http directory.  That worked, after I reset the vif settings to
use bridged networking, and turned on the VMware OUI setting.

Now I'm trying to get VNC working.  This has proved problematic, as the xen0
machine doesn't seem to be able to reach the xenU machine, even using the IP
address.  So work continues.

Thanks for the suggestions.

On 3/19/06, Dario Alcocer <alcocer at> wrote:
> Scott D Hankin wrote:
> > Howdy -
> >
> > I'm attempting to install a FC5 guest in Xen on FC5, 2041 xen0 kernel.
> > I've gotten to the point where anaconda runs and starts presenting me
> > with menus.  Unfortunately, the 3rd menu it presents is stopping me, the
> > one which sets the IP address.
> I've been running with kernel-xen0-2.6.15-1.2041_FC5 with no problems so
> far.  However, I did have problems (thought not with IP address
> assignment) with earlier Xen builds.
> You might check if you have the kernel-xen-hypervisor package installed.
>   I was having problems before when running IIRC .2032; when I upgraded
> to .2041, I removed the hypervisor package, and I've been running Xen
> fine since then.
> > If I select DHCP and networking is set up for NAT, it thinks for a bit
> > and then returns to the same page.  If I try to manually specify an IP
> > address, it thinks for a bit, and then segfaults.  If networking is
> > bridged, it segfaults in either case.
> >
> > The command I'm running is:
> >
> > -n vm2 -f /root/fedora.img -s 6 -r 256 -p -l
> > ftp://mymachine
> >
> > I've tried this with the networking setup as bridged or NAT, but the
> > result is always the same.
> >
> > Any thoughts?
> Maybe you could post your /var/log/xend.log and /var/log/xend-debug.log;
> hopefully others might be able to help given this information.
> --
> Dario Alcocer -- alcocer at
> --
> fedora-test-list mailing list
> fedora-test-list at
> To unsubscribe:

-- Scott
In the beginning, there was nothing, then God said, "Let there be light."
And there was light.  There was still nothing, but you could see it a lot
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the fedora-test-list mailing list