[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NetworkManager 0.6.2; yum problems

Michel Salim wrote:
On 5/1/06, Michel Salim <michel salim gmail com> wrote:
Incidentally, yum --enablerepo=updates-testing update NetworkManager
inexplicably claims that no updates are available; I had to resort to
downloading the RPMs manually. I even tried modifying the
configuration file to point manually to the server that definitely has
the files (mirrors.kernel.org). Updating to yum 2.6.1-0.fc5 does not
help. Has anyone else seen this? I tried resetting the yum caches.

This is on x86_64; yesterday I tried adding i386 repositories to my
configuration (renaming them by appending -i386 to the end), and,
similarly, yum seems to not find the packages I requested even though
it enabled the repositories just fine.
I saw the same myself. First machine: (on i386) /etc/yum.repos.d/fedora-updates-testing enabled=1
yum install yum
got the newer yum that I wanted to test (and also saw all the other test updates).

On a second machine (i386), the same process (with other repos disabled) repeatedly says no updates available. As you mention it could be the random mirror not being up2date, and this was the case for me.

Previously I had also tried modifying the
metadata_expire=1800 to 180000
At the time it was a good idea because it meant pup did not keep going to fetch the repo data stuff every time I started pup / pirut during the day (and I was wanting to do multiple separate package installs).
Reverting it to the default value was a much better idea.

I think the second problem was I had inserted a specific local mirror as the first baseurl and set the order to be sequential, rather than random. This meant the repo data was always downloaded from the specific (I guess not current mirror). At the time it did not have some of the rpms mentioned so yum fell through to the default mirrorlist, which would have had the files.

I decided to manually wipe the cached repo data files for -testing, and this then worked straight away. (could have done yum clean ?

If you could try the following commands, and see if between any of them it begins to work as expected ?
yum clean metadata
yum update ...
yum clean dbcache
yum update ...
yum clean cache
yum update ...
yum clean headers
yum update ...
yum clean packages (wipes out your rpm cache (if you changed a setting to keep it)
yum update ...
yum clean all
yum update ...

Maybe something in the above info will be useful, if not the messages generated by cli yum would be helpful. (maybe with -d higher than 0).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]