[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: system update with yum produces sgmentation fault

Hash: SHA1

parta wrote:
>> > I installed FC5 from cds and then ran 'yum update' to update my system. After
>> > system update, my system has become unstable. Appliations start giving
>> > segmentation fault after running a while. If i restart my system, they run
>> > again perfectly for a while and then segmentation fault pops up. Is there a
>> > way to figure out which package has made my system unstable.
> Random segfaults are usually memory (RAM) problems. Run memtest (it should
> be an option on your installation media boot). When stuff runs OK for a
> while and then starts failing, it could be a overheated CPU (bad fan, etc).

>     Thanks for your response. I acted on this. I ran memtest but it
>     returned no errors. I was using two memory modules from two

I have seen a system with two different memory modules create a bunch of
errors.  Removing a memory module was a good choice.

>     different vendors. I removed on 256M module. Now I have single 512M
>     module and memtested this one also. I monitored operating remprature
>     and system load and they are perfectly normal. I also disabled swap
>     to rule out any corruption in swap. Things have improved but I still
>     get segfaults and application crashes ( frequeny of fauliures is
>     very low now) Is there is anything else I can do to improve the

You could try swapping memory modules.  Since you say that the system
has improved with this module, then try the other.

>     state of my system. My system is not overclocked (one user has
>     suggested that also). 

Once upon a time I had my ram speed set wrong on a motherboard by
accident.  The system failed to boot.  A slightly lower ram speed would
produce overclocked symptoms but not in the CPU sense of the
term--overclocking.  This was on an older motherboard that would allow
you to make changes to these kinds of settings.  Sometimes you can even
reduce ram speed to the point that two different memory modules that are
fighting each will actually start working again.  Mismatched modules can
be a real problem on newer motherboards that try to auto configure the
ram.  The auto configuration may set to the faster of the two memory

There is another memtest that is not turned on by default.  It is
something like 10, 11, or 12.  I don't recall you'll have to look.  I
had one system where the memory in the CPU was bad.  This memtest option
caught the processor problem.  Of course, it was a AMD slot A
motherboard.  By the time the memory in CPU failed, I had to replace
both the motherboard and CPU.  Oh and cheap aluminum capacitors have
been know to fail over time too.

Last option, is that some other heat related part of your system is
failing.  It may not be memory or CPU at all.  If it runs for awhile and
then when it heats up via use and your system fails like you are
describing, then it could be an IC on your network card, motherboard,
video card, on card x, etc.  Overclocking can make this problem worse.
The only way to sort these problems out is if you have the electronic
test systems or other cards that you can swap out one at a time.

For what is worth, I did see something interesting with one of my FC5
systems.  I installed it just fine.  Something happened to the rpm
database on this install and update.  I tried to rebuild the rpm
database.  Didn't work.  I didn't have much into the system so I just
reinstalled and started over.  It works fine now.  Can you try
reinstalling your system after your hardware is running in an acceptable
state?  During the install a binary file could have been damaged if your
memory was screwed up or some other component is failing.  If so, then
no mater what you do to your hardware, your installed system will not
work properly until the damaged file is found an repaired--Good Luck!  I
have consulted high dollar research groups on this configurations like
this.  Your TCO is lower if you just reinstall the thing on working
hardware verses tracking down the failed binary.  Who knows?  Perhaps
part of your file system is damaged?

I hope this helps,

Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]