[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

How to turn off pulseaudio in rawhide



I run an app that calls ALSA library functions in order to determine
sound hardware characteristics and set sound hardware characteristics, in particular the hardware supported frame rates. Since the latest updates in Rawhide this breaks with the following error message:
*** PULSEAUDIO: Unable to connect: Connection refused
cannot open audio device "default" (Connection refused)
Segmentation fault ( <-- the app generated this)

I tried using the kill command with pulseaudio but it won't get rid of
it.  I tried uninstalling pulseaudio, but it still is there.  I went to
services to disable it, and it isn't there either. How do I stop it correctly? I didn't actually ask to have it run so I'm not sure why it is running.

Can Pulseaudio be configured to allow direct access to ALSA?

Can it be bypassed to directly access ALSA while it is running or does it monopolize the sound system?

Is this a bug that should be reported upstream?

Will removing pulseaudio cause any breakages in applications? i.e. is it optional?

Thanks for any clarification and pointers to help.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]