[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: updates repo admission checklist hole



HI ,

It lloks that the hole is still open as now swig package update brokes the update.

$> yum update swig
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package swig.x86_64 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(example) for package: swig-1.3.39-1.fc10.x86_64
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.x86_64
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.x86_64
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.x86_64
--> Running transaction check
---> Package jython-demo.x86_64 0:2.2.1-0.1.Release_2_2_1.1.2.fc10 set to be updated
---> Package swig.x86_64 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.x86_64
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.x86_64
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.x86_64
--> Finished Dependency Resolution
swig-1.3.39-1.fc10.x86_64 from updates has depsolving problems
  --> Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
swig-1.3.39-1.fc10.x86_64 from updates has depsolving problems
  --> Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
swig-1.3.39-1.fc10.x86_64 from updates has depsolving problems
  --> Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
Error: Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
Error: Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
Error: Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

See more here:
https://bugzilla.redhat.com/show_bug.cgi?id=508517

Andrei.



From: Suhan Andrei <sandi_ro yahoo com>
To: fedora-test-list redhat com
Sent: Friday, July 10, 2009 7:03:27 PM
Subject: updates repo admission checklist hole

Hi ,

I think there is a hole in QA process that allows untested packages to get into the update repo.
I may be wrong as well but at least please look into this:

https://bugzilla.redhat.com/show_bug.cgi?id=508517 

as this is a case where a broken package pollute the updates repository.

I am referring about current state of synce-hal package as reported by yum :

$yum list synce-hal
Loaded plugins: refresh-packagekit
Available Packages
synce-hal.x86_64                                       0.13.1-3.fc10                                        updates


PS:  I find here a policy described: http://fedoraproject.org/wiki/PackageSubmissionQAPolicy
but there is no detailed QA Check list , can someone help me with some pointers to follow for more details?

Thanks, Andrei.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]