[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dim Screen




----- Original Message ----- From: "François Cami" <fcami fedoraproject org> To: "For testers of Fedora Core development releases" <fedora-test-list redhat com>
Cc: <jim jbsys com>
Sent: Monday, August 03, 2009 3:27 PM
Subject: Re: Dim Screen



Hi Jim,

On Mon, 3 Aug 2009 14:16:19 -0700
"Jim Bevier" <jim jbsys com> wrote:

Over the last week or more my rawhide AMD x86_64 system w/nvidia GeForce
8600 card has not been working correctly.  If I use nv driver, X will not
start and just hangs showing the last startup text. CTL-ALT-F2 will get a login screen. If I use vesa driver, it also hangs, but shows weird lines on
top and old startup text on bottom of screen.  CTL-ALT-F2 gives a black
screen with no login prompt. I must do reset to restart machine. If I use the nouveau driver, X will start, but the screen is very dark. I am able to login to kde or gnome. I am at the 118 kernel. I think the last one that
worked was in the 60's.  Anybody have something to try?  Any idea what is
broke?

Could you try the following kernel builds from koji and report:
http://koji.fedoraproject.org/koji/buildinfo?buildID=114132
http://koji.fedoraproject.org/koji/buildinfo?buildID=115527
http://koji.fedoraproject.org/koji/buildinfo?buildID=122803

Please install with:
# rpm -i --oldpackage kernel-$version.rpm

Best wishes,

--
fcami


I am sorry this took me so long, I just needed to make some time to do it. I downloaded the suggested kernels (67, 86, and 101) and tried to boot each one using the nouveau driver in xorg.conf. I did not try the nv or vesa drivers. Let me know if you want these tested also. The kernel line in grub.conf had rhgb and quiet parameters on all tests. I had a few other kernels still installed, so I added them to the test. Tests were with 20090728 nouveau driver. Here are the results:

Kernel      X-start?    KDE Login   F2 Console
* 67           No              -                  Yes (large test)
* 86           No              -                  Yes (small text)
  94           No              -                  Yes (small text)
*101          Yes            Dim              Yes (small text)
 103          Yes            Dim              Yes (small text)
 118          Yes            Dim              Yes (small text)
 122          Yes            Dim              Yes (small text)

It seems the last working kernel for me was before 67.  Maybe 64?

I did some more testing and noticed I was running with "DefaultDepth 16" set in the xorg.conf file. I changed this to "DefaultDepth 24" and I not get the normal bright login screen. It seems someone, somewhere has assumed a 24 bit color depth when they should be testing for 16 (maybe even 8 or 15). I retested and 67, 86, and 94 still do allow X to start. Kernels 101, 103, 118, and 122 are now at full brightness. So something was changed before kerenel 101 that ignores the DefaultDepth parameter.

Hope this helps.

Jim
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]