[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????



On Mon, 10 Aug 2009 05:23:41 -0700 (PDT), Antonio wrote:

> 
> 
> --- On Fri, 8/7/09, Adam Williamson <awilliam redhat com> wrote:
> 
> > From: Adam Williamson <awilliam redhat com>
> > Subject: Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????
> > To: "For testers of Fedora Core development releases" <fedora-test-list redhat com>
> > Date: Friday, August 7, 2009, 11:37 PM
> > On Sat, 2009-08-08 at 08:08 +0200,
> > Michael Schwendt wrote:
> > > On Sat, 8 Aug 2009 11:26:53 +0530, Vishal wrote:
> > > 
> > > > haven't been following this thread in detail but
> > have you seen
> > > > http://rawhidewatch.wordpress.com/2009/07/31/unable-to-update-to-rawhide-rpmlibpayloadisxz/
> > 
> > > It's out-of-date as it's a week old already. The
> > needed RPM is distributed within
> > > Rawhide as I showed in my previous reply.
> > 
> > It's not out of date. We intentionally decided the F11
> > workaround is
> > better as it requires fewer packages to be updated, and is
> > tested to
> > work.
> > 
> > -- 
> 
> I am sorry to all, but none of the suggestions work :(

You've missed the window during which the .fc11 RPM was offered
in rawhide.

Instead, you now get only a newer RPM build for .fc12, which depends on a
newer glibc and xz, which cannot be installed because they require a newer
RPM first. Chicken and egg.

The only way to escape from that is the old work-around mentioned earlier
in this thread. Disable rawhide repo, and update to the .fc11 RPM packages
from updates-testing, 4.7.1-1.fc11.

Sort of:

  yum --disablerepo=rawhide --enablerepo=updates-testing update rpm
  yum update yum
  yum update


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]