[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????



On Tue, Aug 11, 2009 at 04:47:17AM -0700, Antonio Olivares wrote:
> 
> 
> I am/was getting desperate here.

"Desperate" still does not mean "some random actions in blind".

>  None of the strategies worked, the above commands still return back
> 
> error: Failed dependencies:
>  liblzma.so.0 is needed by
>  rpm-4.7.1-1.fc11.i586
> 
> can't do much  :(

Yes, you can.  Get a complete set of rpm packages (possibly from
updates-testing for f11) , together with _all_ dependencies, and use
rpm2cpio to pipe cpio content to 'cpio -imd' to unpack all of this
below some scratch directory.  Copy resulting files, keeping all
directory structure, to expected places and you should be back in
business to straighten all this mess.  That includes bringing back
yours rpm database which after first steps will be out of sync.

If rpm2cpio gives you dependency grief you may do the above on
another machine and copy results.  Last but not least it is not that
difficult to unpack rpm packages using only shell plus some standard
programs.  Shell scripts to do just that should be possible to find
if you will look around.


   Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]