[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????

--- On Tue, 8/11/09, Michael Schwendt <mschwendt tmp0701 nospam arcor de> wrote:

> From: Michael Schwendt <mschwendt tmp0701 nospam arcor de>
> Subject: Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????
> To: fedora-test-list redhat com
> Date: Tuesday, August 11, 2009, 6:24 AM
> On Tue, 11 Aug 2009 04:47:17 -0700
> (PDT), Antonio wrote:
> > I am/was getting desperate here.  None of the
> strategies worked, the above commands still return back
> > 
> > error: Failed dependencies:
> >  liblzma.so.0 is needed by
> >  rpm-4.7.1-1.fc11.i586
> > 
> > can't do much  :(
> Antonio, with all due respect, why did you update "rpm"
> with --nodeps?
> It's a great way to shoot yourself into the feet.
> Does your /bin/rpm still work? (The executable depends on
> liblzma.so.0
> which you choose to ignore with your --nodeps command)
> Can you use your rpm to install the missing rpm-libs and
> xz-libs packages
> from f11 updates-testing? Or does the command fail?
> If it fails, "yum localinstall ..." of the missing fc11
> packages might
> be the last way out (under the assumption that your older
> rpm-libs
> and rpm-python packages still work independently of the
> --nodeps rpm
> thing). Otherwise you've lost, as you would need to be
> familiar with
> a rescue disk to fix your RPM.
> Further, you're the undisputed master of quoting too much.
> :-/
> Way too much irrelevant stuff. That's not helpful.
> > [root localhost packages]# yum update rpm
> What are you trying to do there? Have you finished
> installing the needed
> rpm-libs and xz-libs packages? Nothing in your quotes shows
> that you
> completed that step.
> > [root localhost packages]# yum remove rpm
> Oh, come on! You're a subscriber of this list and a user of
> Fedora and
> Rawhide for a long time. What results do you expect from
> "yum remove rpm"?
> If you really think it would let you erase your RPM tools
> and libraries,
> you would need to be prepared to recover with a rescue
> disc. Because
> "no RPM" => no way to install any packages.
> All you needed to do is to update a few packages manually.
> -- 


I appreciate your help through this and other situations that you have helped me out of.  I got desperate here and tried the --nodeps --force option.  Then I got the lzma.so error, I download and compiled xz-.... tar.gz file, and ran ldconfig and got passed the other error.  Still things do not look too good.  This xz package(s) or series of killed or shattered this machine.  I have managed rawhide through the years and these problems here, I guess I can't overcome them.  I have downloaded xfce weeky posted by another rawhider (08-10 or something like that).  Probably my best way out of this, is to nuke this machine and install the xfce weekly iso and start back from there, I looked for Alpha Isos, but they are not ready yet.  

Sorry for quoting too much, I was trying to post all the stuff that I tried to do, but still got nowhere :(

Will see how soon I can get this machine back into running form.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]