[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 2009-08-27 - Fedora test day - Dracut



On Tue, 25 Aug 2009 14:44:11 -0400
James Laska <jlaska redhat com> wrote:

> It is worth noting that dracut will impact *every* Fedora 12 user (and
> potentially users of other distros).  As a result, there are several
> ways to get involved with testing, ranging from basic to more
> advanced:
> 

>      2. Update your existing Fedora 11 (or Fedora 12 Alpha) system(s)
> to use dracut, and reboot 

Just for fun I installed dracut on my F11 x86_64 system.  Then I read
web documents until I had some idea of what it was doing.

I created an initramfs in boot from the currently running kernel.
dracut -v --debug -H test_dracut-initramfs.cpio.gz 

When it came time to use my shiny new initramfs, the option I wanted
seemed to be dracut-gencmdline.  So I ran it.  And it wasn't found.  I
went to this link and it seems to imply it should
http://fedoraproject.org/wiki/Dracut/Options#Dracut-gencmdline
Eventually, I realized there was more than the dracut package, and
installed all of the dracut packages.

A little more reading said that I could just use a regular kernel line
in /boot/grub/menu.lst.  So I used this stanza to boot:

  title Fedora (2.6.30.5-32.20090821.fc11.x86_64.dracut)
    root (hd2,0)
    kernel /vmlinuz-2.6.30.5-32.20090821.fc11.x86_64 root=UUID=c94b5547-e098-45ca-8776-cce0e0cd6bac vga=0x318 init=/sbin/bootchartd
    initrd /test_dracut-initramfs.cpio.gz

However, a reboot eventually arrived at a screen telling me it couldn't
find the root device and it was going to sleep forever.

What did I miss?

I suspect the documentation is aimed at people more familiar with this
process than I am, and so some details I need are missing.

The kernel command line it generates doesn't have my vga=0x318 option on
it.  At least it doesn't show it when I run dracut-gencmdline.  If I
can get it to boot, I'll use a console and see if it was actually
there but not noted.  And it adds an option that I don't have (or want),
rd_plytheme=charge.

While it is running, ctrl-C does nothing.  Well, it shows a prompt
momentarily, then dracut continues.  If you make a mistake, you have to
go all the way.

I couldn't use less on the output in order to see it.  And redirection
failed as well.  Not much point in verbose or debug output if it scrolls
into the bit bucket.

Could you put a working grub stanza somewhere in the documentation so it
is easy to see what should work.  I tried all kinds of variations on the
above and couldn't get any to work.

There won't be much testing if people have the experience I have had.
:-)
But it sure sounds like a great idea.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]