[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20090826 changes



On Thu, 27 Aug 2009 00:42:43 +0100, Peter wrote:

> On Thu, Aug 27, 2009 at 12:33 AM, Brian Pepple wrote:
> > On Wed, 2009-08-26 at 15:58 +0100, Peter Robinson wrote:
> >> > Broken deps for i386
> >> > ----------------------------------------------------------
> >> >        anerley-0.0.20-3.fc12.i686 requires libmissioncontrol-client.so.0
> >> >        anerley-devel-0.0.20-3.fc12.i686 requires pkgconfig(libmissioncontrol)
> >> >        anjal-0.1.0-0.7.20090821git5ac8bfe.fc12.i686 requires libmissioncontrol-client.so.0
> >> >        empathy-2.27.5-3.fc12.i686 requires libmissioncontrol-client.so.0
> >> >        empathy-devel-2.27.5-3.fc12.i686 requires pkgconfig(libmissioncontrol)
> >> >        empathy-libs-2.27.5-3.fc12.i686 requires libmissioncontrol-client.so.0
> >> >        empathy-python-2.27.5-3.fc12.i686 requires libmissioncontrol-client.so.0
> >> >        nautilus-sendto-1.1.6-2.fc12.i686 requires libmissioncontrol-client.so.0
> >>
> >> I don't remember the bump nitrification email for this going to fedora-devel.
> >
> > My fault.  I wasn't aware of anything using mission-control other than
> > empathy & nautilus-sendto which I was working on updating.  Sorry.
> 
> No problems. If you can help out with what needs to be done for
> anerley that would be great as I've not had anything to do with
> telepathy-mission-control. Anjal depends on anerley and that's why its
> complaining.

pkgconfig(libmissioncontrol) changed to pkgconfig(libmcclient).
That already breaks anerley.
Could be an API change in telepathy-mission-control-devel.

Both anerley and anjal are linked with libmissioncontrol-client.so.0
because anerley's pkgconfig file has Requires on several other packages
as it doesn't encapsulate those APIs but exposes them in its headers.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]