[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Abobe Reader doesn't work with current Rawhide



On Thu, 2009-08-27 at 11:05 -0600, Michal Jaegermann wrote:
> On Wed, Aug 26, 2009 at 10:11:42PM -0400, Matthias Clasen wrote:
> > 
> > If you showed us some details of the crash, we might be able to tell
> > you...
> 
> By editing 'acroread' script to run binaries under gdb you can find
> the following:
> 
> Program received signal SIGSEGV, Segmentation fault.
> 0xf67c55b9 in gdk_window_get_geometry () from /usr/lib/libgdk-x11-2.0.so.0
> (gdb) where
> #0  0xf67c55b9 in gdk_window_get_geometry () from /usr/lib/libgdk-x11-2.0.so.0
> #1  0x084f4219 in _start ()
> 
> 
> This is with gtk2-2.17.9-1.fc12.i686 and does not happen with
> gtk2-2.16.5-1.fc11.i586 on Fedora 11.  I am afraid that in this
> moment I cannot look at that deeper.  Maybe later if somebody is not
> going to beat me to it.
> 
> Another possible problem is that for x86_64 Fedora 11, and earlier,
> supply gtk2-engines.i?86 and in rawhide repositories you can find only
> gtk2-engines.x86_64.  Acroread appears to be using that even if that
> is not made explicit in rpm packages from Adobe.  No idea if this is
> really critical.  It surely make for tons of complaints.
> 
>    Michal
> 

If you have GTK+ 2.17.9, does running 

GDK_NATIVE_WINDOWS=1 acroread

work any better ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]