[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Abobe Reader doesn't work with current Rawhide



On Thu, Aug 27, 2009 at 01:11:34PM -0400, Matthias Clasen wrote:
> On Thu, 2009-08-27 at 11:05 -0600, Michal Jaegermann wrote:
> > On Wed, Aug 26, 2009 at 10:11:42PM -0400, Matthias Clasen wrote:
> > > 
> > > If you showed us some details of the crash, we might be able to tell
> > > you...
> > 
> > By editing 'acroread' script to run binaries under gdb you can find
> > the following:
> > 
> > Program received signal SIGSEGV, Segmentation fault.
> > 0xf67c55b9 in gdk_window_get_geometry () from /usr/lib/libgdk-x11-2.0.so.0
> > (gdb) where
> > #0  0xf67c55b9 in gdk_window_get_geometry () from /usr/lib/libgdk-x11-2.0.so.0
> > #1  0x084f4219 in _start ()
> 
> If you have GTK+ 2.17.9, does running 
> 
> GDK_NATIVE_WINDOWS=1 acroread
> 
> work any better ?

Yes, indeed, it does.  Also editing 'acroread' script to put
GDK_NATIVE_WINDOWS=1 in front of 'exec' in a LaunchBinary function
provides, in this moment, a workaround.

Missing on x86_64 gtk2-engines.i686 does not seem to be critical but
that surely generates a lot and lot of spillage like that:

(acroread:2509): Gtk-WARNING **: Unable to locate theme engine in
module_path: "clearlooks",

which does go away after gtk2-engines.i686 package is installed.

    Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]