[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

more rpmlib(PayloadIsXz) woes



Hi guys,
I've seen a few messages regarding this problem, but can't figure out where to start.
I had a nice working fc11 which I was doing "yum update" to, and has suddenly "converted" to updating from fc12 (which baffled me for starters).
Now it is no longer stable (a nasty Dell box) but I can't continue updating with yum due to the reknown rpmlib problem.
Obviously "yum update" fails, so I tried the regular:
yum --enablerepo=updates-testing update rpm
which also fails (print below).
How do I move forward? (thanks, and sorry for the repeat).
I'm also including output from rpm -qa rpm\*:
---
# rpm -qa rpm\*
rpm-python-4.7.0-8.fc12.i586
rpm-devel-4.7.0-8.fc12.i586
rpm-libs-4.7.0-8.fc12.i586
rpm-build-4.7.0-8.fc12.i586
rpm-4.7.0-8.fc12.i586
---
# yum --enablerepo=updates-testing update rpm
Loaded plugins: dellsysidplugin2, refresh-packagekit
updates-testing/metalink                                 |  16 kB     00:00
updates-testing                                          | 3.7 kB     00:00
updates-testing/primary_db                               | 9.3 MB     02:14
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: rpm = 4.7.0-8.fc12 for package: rpm-python-4.7.0-8.fc
12.i586
--> Processing Dependency: rpm = 4.7.0-8.fc12 for package: rpm-libs-4.7.0-8.fc12
.i586
--> Processing Dependency: rpm = 4.7.0-8.fc12 for package: rpm-build-4.7.0-8.fc1
2.i586
--> Processing Dependency: rpm = 4.7.0-8.fc12 for package: rpm-devel-4.7.0-8.fc1
2.i586
---> Package rpm.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: liblzma.so.0 for package: rpm-4.7.1-4.fc12.i686
--> Running transaction check
---> Package rpm-build.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: xz for package: rpm-build-4.7.1-4.fc12.i686
---> Package rpm-devel.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: xz-devel >= 4.999.8 for package: rpm-devel-4.7.1-4.fc
12.i686
---> Package rpm-libs.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: libc.so.6(GLIBC_2.11) for package: rpm-libs-4.7.1-4.f
c12.i686
---> Package rpm-python.i686 0:4.7.1-4.fc12 set to be updated
---> Package xz-libs.i686 0:4.999.8-0.10.beta.20090817git.fc12 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.10.1-2 for package: glibc-headers-2.10.1-2.
i586
--> Processing Dependency: glibc = 2.10.1-2 for package: glibc-common-2.10.1-2.i
586
--> Processing Dependency: glibc = 2.10.1-2 for package: glibc-devel-2.10.1-2.i5
86
---> Package glibc.i686 0:2.10.90-15 set to be updated
---> Package xz.i686 0:4.999.8-0.10.beta.20090817git.fc12 set to be updated
---> Package xz-devel.i686 0:4.999.8-0.10.beta.20090817git.fc12 set to be update
d
--> Running transaction check
---> Package glibc-common.i686 0:2.10.90-15 set to be updated
---> Package glibc-devel.i686 0:2.10.90-15 set to be updated
---> Package glibc-headers.i686 0:2.10.90-15 set to be updated
--> Processing Conflict: glibc-2.10.90-15.i686 conflicts prelink < 0.4.2
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package prelink.i686 0:0.4.2-2.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch Version                               Repository       Size
================================================================================
Updating:
 prelink       i686 0.4.2-2.fc12                          rawhide         955 k
 rpm           i686 4.7.1-4.fc12                          rawhide         825 k
Installing for dependencies:
 xz            i686 4.999.8-0.10.beta.20090817git.fc12    updates-testing  99 k
 xz-devel      i686 4.999.8-0.10.beta.20090817git.fc12    updates-testing  34 k
 xz-libs       i686 4.999.8-0.10.beta.20090817git.fc12    updates-testing  89 k
Updating for dependencies:
 glibc         i686 2.10.90-15                            updates-testing 2.8 M
 glibc-common  i686 2.10.90-15                            rawhide         5.9 M
 glibc-devel   i686 2.10.90-15                            rawhide         945 k
 glibc-headers i686 2.10.90-15                            rawhide         526 k
 rpm-build     i686 4.7.1-4.fc12                          rawhide         110 k
 rpm-devel     i686 4.7.1-4.fc12                          rawhide          77 k
 rpm-libs      i686 4.7.1-4.fc12                          rawhide         300 k
 rpm-python    i686 4.7.1-4.fc12                          rawhide          43 k

Transaction Summary
================================================================================
Install       3 Package(s)
Upgrade      10 Package(s)

Total size: 13 M
Total download size: 4.4 M
Is this ok [y/N]: y
Downloading Packages:
(1/9): glibc-2.10.90-15.i686.rpm                         | 2.8 MB     00:33
(2/9): rpm-4.7.1-4.fc12.i686.rpm                         | 825 kB     00:10
(3/9): rpm-build-4.7.1-4.fc12.i686.rpm                   | 110 kB     00:01
(4/9): rpm-devel-4.7.1-4.fc12.i686.rpm                   |  77 kB     00:01
(5/9): rpm-libs-4.7.1-4.fc12.i686.rpm                    | 300 kB     00:04
(6/9): rpm-python-4.7.1-4.fc12.i686.rpm                  |  43 kB     00:00
(7/9): xz-4.999.8-0.10.beta.20090817git.fc12.i686.rpm    |  99 kB     00:01
(8/9): xz-devel-4.999.8-0.10.beta.20090817git.fc12.i686. |  34 kB     00:00
(9/9): xz-libs-4.999.8-0.10.beta.20090817git.fc12.i686.r |  89 kB     00:01
--------------------------------------------------------------------------------
Total                                            74 kB/s | 4.4 MB     01:00
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-common-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-build-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-headers-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-devel-4.999.8-0.10.beta.20090817git
.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-python-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-libs-4.999.8-0.10.beta.20090817git.
fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-libs-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-devel-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-4.999.8-0.10.beta.20090817git.fc12.
i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by prelink-0.4.2-2.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-devel-4.7.1-4.fc12.i686
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]