[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: more rpmlib(PayloadIsXz) woes



> On Fri, Aug 28, 2009 at 03:28:05PM -0400, John Broomfield wrote:
> > all" and then simply "yum update rpm" which also fails. Find below
> > the whole output from it.
> ....
> > Updating:
> >  prelink         i686   0.4.2-2.fc12                            rawhide   955 k
> >  rpm             i686   4.7.1-4.fc12                            rawhide   825 k
> are seeing here "fc12" then you are in the wrong place.  First you
> need to update rpm packages using Fedora 11 repos (updates,
> updates-testing, whatever) , i.e. with 'rawhide' repos _disabled_,
> and only then you can go back to rawhide.
> 
>    Michal

Hi Michal and thanks for your patience with me. I've disabled the rawhide now, and only getting from the updates-testing repos, but it still shows fc12 in the name, and (as usual...) still bombs with the same error. How do I force to take fc11 from the updates-testing repos? (or shouldn't I be doing that?).
Sorry for making a complete fool of myself here... :(
John.


---
yum --enablerepo=updates-testing update rpm*
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rpm.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: liblzma.so.0 for package: rpm-4.7.1-4.fc12.i686
---> Package rpm-build.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: xz for package: rpm-build-4.7.1-4.fc12.i686
---> Package rpm-devel.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: xz-devel >= 4.999.8 for package: rpm-devel-4.7.1-4.fc
12.i686
---> Package rpm-libs.i686 0:4.7.1-4.fc12 set to be updated
--> Processing Dependency: libc.so.6(GLIBC_2.11) for package: rpm-libs-4.7.1-4.f
c12.i686
---> Package rpm-python.i686 0:4.7.1-4.fc12 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.10.1-2 for package: glibc-headers-2.10.1-2.
i586
--> Processing Dependency: glibc = 2.10.1-2 for package: glibc-common-2.10.1-2.i
586
--> Processing Dependency: glibc = 2.10.1-2 for package: glibc-devel-2.10.1-2.i5
86
---> Package glibc.i686 0:2.10.90-15 set to be updated
---> Package xz.i686 0:4.999.8-0.10.beta.20090817git.fc12 set to be updated
---> Package xz-devel.i686 0:4.999.8-0.10.beta.20090817git.fc12 set to be update
d
---> Package xz-libs.i686 0:4.999.8-0.10.beta.20090817git.fc12 set to be updated
--> Running transaction check
---> Package glibc-common.i686 0:2.10.90-15 set to be updated
---> Package glibc-devel.i686 0:2.10.90-15 set to be updated
---> Package glibc-headers.i686 0:2.10.90-15 set to be updated
--> Processing Conflict: glibc-2.10.90-15.i686 conflicts prelink < 0.4.2
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package prelink.i686 0:0.4.2-2.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch Version                               Repository       Size
================================================================================
Updating:
 prelink       i686 0.4.2-2.fc12                          updates-testing 955 k
 rpm           i686 4.7.1-4.fc12                          updates-testing 825 k
 rpm-build     i686 4.7.1-4.fc12                          updates-testing 110 k
 rpm-devel     i686 4.7.1-4.fc12                          updates-testing  77 k
 rpm-libs      i686 4.7.1-4.fc12                          updates-testing 300 k
 rpm-python    i686 4.7.1-4.fc12                          updates-testing  43 k
Installing for dependencies:
 xz            i686 4.999.8-0.10.beta.20090817git.fc12    updates-testing  99 k
 xz-devel      i686 4.999.8-0.10.beta.20090817git.fc12    updates-testing  34 k
 xz-libs       i686 4.999.8-0.10.beta.20090817git.fc12    updates-testing  89 k
Updating for dependencies:
 glibc         i686 2.10.90-15                            updates-testing 2.8 M
 glibc-common  i686 2.10.90-15                            updates-testing 5.9 M
 glibc-devel   i686 2.10.90-15                            updates-testing 945 k
 glibc-headers i686 2.10.90-15                            updates-testing 526 k

Transaction Summary
================================================================================
Install       3 Package(s)
Upgrade      10 Package(s)

Total size: 13 M
Total download size: 9.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/9): glibc-common-2.10.90-15.i686.rpm                  | 5.9 MB     01:25
(2/9): glibc-devel-2.10.90-15.i686.rpm                   | 945 kB     00:11
(3/9): glibc-headers-2.10.90-15.i686.rpm                 | 526 kB     00:09
(4/9): prelink-0.4.2-2.fc12.i686.rpm                     | 955 kB     00:12
(5/9): rpm-4.7.1-4.fc12.i686.rpm                         | 825 kB     00:11
(6/9): rpm-build-4.7.1-4.fc12.i686.rpm                   | 110 kB     00:02
(7/9): rpm-devel-4.7.1-4.fc12.i686.rpm                   |  77 kB     00:02
(8/9): rpm-libs-4.7.1-4.fc12.i686.rpm                    | 300 kB     00:06
(9/9): rpm-python-4.7.1-4.fc12.i686.rpm                  |  43 kB     00:00
--------------------------------------------------------------------------------
Total                                            67 kB/s | 9.6 MB     02:26
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-common-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-build-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-headers-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-devel-4.999.8-0.10.beta.20090817git
.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-python-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-libs-4.999.8-0.10.beta.20090817git.
fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-libs-4.7.1-4.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-devel-2.10.90-15.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-4.999.8-0.10.beta.20090817git.fc12.
i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by prelink-0.4.2-2.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-devel-4.7.1-4.fc12.i686
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]