[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Broke my system trying to upgrade to rawhide using yum



I know this is long after your original post -- but it is problems like what you and others experience that persuades me to always install any alpha or beta code to a totally different hard drive than the one my "working" Fedora system is on. I just tried installing Fedora 12 Alpha and I did get a nice runlevel 3 system...which of course is broken with respect to X. Luckily I had taken the trouble to pop a spare hard drive in my laptop, and put my Fedora 11 hard drive on a shelf for several hours. I didn't lose anything and got some experience with the alpha code.

Bob



On 07/13/2009 08:40 PM, suvayu ali wrote:
2009/7/13 Horst H. von Brand<vonbrand inf utfsm cl>:
suvayu ali<fatkasuvayu+rawhide gmail com>  wrote:
Today I finally gathered up the courage to "live on the edge" and
upgrade to rawhide. So I disabled all the other repositories and
enabled rawhide. (Fedora and rpmfusion, living rpmfusion enabled was
probably a bad idea) Then I ran
;-)

Here I also got an unbootable system, it looks like by cron automatically
running prelink(8). The steps here were:

  - Got boot.iso from a rawhide mirror (not all carry them!),
    dated 2009-07-07 (latest I could find)
  - Rescue mode complained there aren't any Linux partitions. Panic time!
    But they are there, lvscan shows everything inactive (?)...

  # lvm
    lvm>  lvchange -a y /dev/VolGroup/LogVol00
         ....
  # mount<lots of /dev/VolGroup00/LogVol?? under /mnt/sysimage>
  # chroot /mnt/sysimage prelink -u -a

After the above, I could run yum:

  # chroot /mnt/sysimage yum -y update --skip-broken

Several complaints about not being able to run %pre/%post later, I
rebooted normally, everything works (slowly, but better than not at all ;-)

Ran as root:

  # package-cleanup --clean-dupes

And then did a:

  # yum -y reinstall<list of packages with dupes from above>

just to be on the safe side WRT packages that didn't uninstall/install
cleanly. I'm pretty sure the above didn't catch them all, but...
Thanks for your reply, but I couldn't get my box to boot so finally
reinstalled F11 on it. :(



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]