[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fedora 11 alpha nfs not listening on udp port 2049?

On Wed, 4 Mar 2009, seth vidal wrote:

> On Tue, 2009-03-03 at 19:02 -0500, Robert P. J. Day wrote:
> > for the first time, i'm trying to boot an embedded system via NFS
> > mounting its root fs from my f11 alpha system, and the attempt to
> > mount that root fs simply hangs.  invoking tcpdump shows continuous
> > diagnostics claiming that, on the server side, "udp port nfs
> > unreachable."
> >
> >   sure enough, even though "service nfs start" worked fine, running
> > "netstat -an" shows nothing listening on port 2049 on the server.
> > however, "ps -ef" shows multiple [nfsd] processes (threads?) running.
> >
> >   that would explain it if nothing is listening on port 2049.  on
> > another system here that acts very nicely as an NFS server (running
> > RHEL4), if i run "netstat -an", i can see both a UDP and TCP listener
> > on that port, plus numerous established connections from clients
> > mounting.
> >
> >   but on f11 alpha ... nothing.  where went port 2049?
> >
> I think, though I may be forgetting, that nfsv4 is now the default.
> Have you explicitly enabled nfsv3?

  um, no.  should i wander off and read the release notes?  :-)  and,
per my earlier posting, i'm now trying this between two f11 alpha
boxes with similar unproductive results.  and i would think that two
f11 alpha box defaults shouldn't need any tweaking or extra config,
but i could be wrong.


Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry:
    Have classroom, will lecture.

http://crashcourse.ca                          Waterloo, Ontario, CANADA

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]