[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel video testing: It worked for a bit...

Leon Stringer wrote:

After the many comments and suggestions following my post last week I
tried F11A on my Intel D845GERG2-based system.

Anaconda didn't work with the default driver (same bug as #470371 in
F10) but worked fine with the Basic Video Driver option.

First boot, black screen but setting Option "NoAccel" "true" fixed that
(using the VESA driver).

So I could get into X, set up my Wi-Fi card and download the updates.

Now it doesn't work again!

With no X, I have no Wi-Fi so I tried manually updating some packages
from a mirror and now things are looking a bit strange, I've lost the
text-based progress bar at the start.

So, have I done anything wrong by applying these?

  - xorg-x11-drv-i810-2.6.0-7.fc11.i586.rpm
  - kernel-2.6.29-0.237.rc7.git4.fc11.i586.rpm
  - kernel-firmware-2.6.29-0.237.rc7.git4.fc11.noarch.rpm
  - xorg-x11-drv-nouveau-0.0.12-10.20090310git8f9a580.fc11.i586.rpm
  - libdrm-2.4.5-0.fc11.i586.rpm
  - libdrm-devel-2.4.5-0.fc11.i586.rpm

Advice and assistance gratefully received,

The xorg-x11-drv-nouveau should be irrelevant if you're using intel graphics.

Also, you should use xorg-x11-drv-intel-2.6.0-14.fc11.i586.rpm for
the latest;  Yum/rawhide changed me from -i810 to -intel at some point.
I have a intel 845G/GL[Brookdale-G] 8086:2562 rev3 on a Dell laptop.
From yesterday's testing:

.. it appears the KMS (on by default) doesn't set up the 845G correctly.
Boot with "nomodeset" on the kernel boot line.

If the screen goes black, toggle around the VT's (clt-alt-Fn) to restore it.
With nomodeset, the text VT backlights always work.  There seems to be a
race condition in re-enabling the screen backlight with the intel Xserver.

Hope this helps,
-Bob Arendt

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]