[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel video testing: It worked for a bit...

Bob Arendt wrote:
Leon Stringer wrote:
Robert Arendt wrote:
Also, you should use xorg-x11-drv-intel-2.6.0-14.fc11.i586.rpm for
the latest;  Yum/rawhide changed me from -i810 to -intel at some point.
I have a intel 845G/GL[Brookdale-G] 8086:2562 rev3 on a Dell laptop.

Bob: Thanks for your reply. Unfortunately, I can't get this to work for
me. I did:
   rpm -i xorg-x11-drv-intel-2.6.0-14-fc11.i586

And I've tried all the tests I think could possibly work:

2. Driver "intel"+nomodeset: X attempts to load, see mouse cursor
briefly, then blank, system locked up

Case 2 is the one that works the best for me.  Though 1 is the goal
of the intel Xorg and kernel developers.  My grub entry:
title Fedora (2.6.29-0.237.rc7.git4.fc11.i586)
        root (hd0,0)
kernel /vmlinuz-2.6.29-0.237.rc7.git4.fc11.i586 ro rootwait root=UUID=[bigstring] selinux=0 rhgb nomodeset
        initrd /initrd-2.6.29-0.237.rc7.git4.fc11.i586.img

Are you sure your machine is locking up?  For me the acid test is
to toggle the caps-lock key and see if the indicator light toggles.
If not, the machine's locked up.  Also ping or ssh in from another
host.  Often it was the backlight failure that made it appear to be
totally dead.

To get more diagnostics, again try booting with "nomodeset 3"
(to start at runlevel 3, without X).  Log into a VT and type:
  startx /usr/bin/xterm -- -logverbose 255

This should start an Xserver and xterm (yum install /usr/bin/xterm)
on vt7.  This is sort of a failsafe mode - not even a window manager.
It takes gdm and the rest of the gnome session out of the equation.
When you exit the xterm, the Xserver will terminate.  The logverbose
puts maximum debug into the /var/log/Xorg.0.log.

If you got an xterm, you can start a window manager wiht "metacity &".
Now you have borders and can drag the xterm.  Maybe try simple tests
like "x11perf -putimage100" (2D)  or "glxgears" (3D).  This will
give you some simple numeric benchmarks to compare to other systems.

I feel your pain, I've been testing this hardware since F10 alpha (last Halloween):

It looks like it's getting a lot closer, but the 845G hardware isn't
out of the woods yet.

Good luck,
-Bob Arendt

When I say "locks up" I find Num Lock/Caps Lock lights toggle initially but stop after a few seconds. I can't switch to a virtual terminal either. (This is a desktop machine so I don't get any backlight issues).

However, the basic startx xterm... test worked and I can load Metacity and glxgears runs.

So I'm a bit baffled, if I can get a minimal X running, what's missing that prevents GNOME running?

And thanks for your help so far Bob, at least I feel I'm getting somewhere (albeit slowly!).

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]