[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel video testing: It worked for a bit...

Robert Arendt wrote:
Leon Stringer wrote:
Bob Arendt wrote:
Leon Stringer wrote:
Robert Arendt wrote:
To get more diagnostics, again try booting with "nomodeset 3"
(to start at runlevel 3, without X).  Log into a VT and type:
  startx /usr/bin/xterm -- -logverbose 255

This should start an Xserver and xterm (yum install /usr/bin/xterm)
on vt7.  This is sort of a failsafe mode - not even a window manager.
It takes gdm and the rest of the gnome session out of the equation.
When you exit the xterm, the Xserver will terminate.  The logverbose
puts maximum debug into the /var/log/Xorg.0.log.

However, the basic startx xterm... test worked and I can load Metacity
and glxgears runs.

So I'm a bit baffled, if I can get a minimal X running, what's missing
that prevents GNOME running?

Great!  Looks like the Xserver is mostly working.  It could be that
gdm is having problems starting up, or pulseaudio might be hitting your
system and causing it to lock up.

If you look in /var/log/messages just prior to the start of the current
boot, do you see anything that could indicate a problem?  Also gdm
(the login manager) is spitting out *lots* of diagnostics into the log.
If it freezes, it's probably somewhere during gdm startup, since it
starts X (maybe does sound and animations) before presenting a login box.

Instead of this fail-safe login, try starting gnome-session or kde
instead of xterm.  As before, boot to runlevel 3, log in, and:
  startx /usr/bin/gnome-session -- -logverbose 255
  startx /usr/bin/startkde -- -logverbose 255
(I think startkde is the session startup script, not sure ...)

You should be able to log in as a non-root user and start a session
this way.  If there are problems, you might consider starting from
a new user's directory;  Some configuration changes seem to have made
some gnome settings incompatible with previous versions.  Also new-users
have "Desktop Effects" turned off by default (the "effects" cause a
lock-up just as you describe).

If these work, then it's certainly something associated with gdm (gnome
display manager).  It's the one that starts X, puts up a login screen,
and possibly gets fancy with some sound and animation in F11 .. which
might be killing you.  Although glxgears works, trying to enable
"Desktop effects" froze me completely (no capslocks or network).
If gdm is trying to do compositing, that may be the killer.

If the gnome-session login doesn't work, maybe it's not X at all ..
maybe it's trying to play a sound and it locks up.  To test this,
boot to runlevel 3, log in as root, and start pulseaudio manually:
   pulseaudio --kill
   pulseaudio --start
   paplay /usr/share/sounds/startup*.wav

There should be a number of files in that directory.  F10 has startup3.wav.
If this works, pulseaudio probably isn't the killer.

startx gnome-session... loads X, then I'm prompted for my credentials for Network Manager but apart from that the screen is black. I tried creating a new user to rule out any of my config files but got the same results. But, unless you know this should work, I'm wondering if GNOME requires some to be launched by GDM to work. I'll see if I can comment out the items GNOME runs at startup to see if that makes a difference.

paplay worked so it's probably not that.

Not much fun, but thanks for all your suggestions...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]