[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel video testing: It worked for a bit...

Bob Arendt wrote:
Leon Stringer wrote:
Robert Arendt wrote:

startx gnome-session... loads X, then I'm prompted for my credentials
for Network Manager but apart from that the screen is black. I tried
creating a new user to rule out any of my config files but got the same
results. But, unless you know this should work, I'm wondering if GNOME
requires some to be launched by GDM to work. I'll see if I can comment
out the items GNOME runs at startup to see if that makes a difference.

paplay worked so it's probably not that.

Not much fun, but thanks for all your suggestions...
You've stumped me at this point.  There do appear to be issues starting
a gnome-session as root;  Lots of gnome desktop bits don't want to run
as root.  For me it will start from runlevel 3 as an ordinary or new user.
But on this laptop the the backlight control is eratic.  Maybe this
translates into some sort of erratic video control for a connected monitor.
Also my laptop screen is a mere 1024x768.

Last parting words - you might check using xrandr through an external
terminal.  To make Xserver authorization work, find the auth file:
  $ ps -eo args |grep X
xinit /usr/bin/gnome-session -- /usr/bin/X -logverbose 255 -auth /home/me/.serverauth.3625
  /usr/bin/X :0 -logverbose 255 -auth /home/me/.serverauth.3625
  $ export XAUTHORITY=/home/me/.serverauth.3625
  $ export DISPLAY=:0
  $ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 1024
VGA disconnected (normal left inverted right x axis y axis)
LVDS unknown connection 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+   60.0
   800x600        60.3
   640x480        59.9

.. So you can check with xrandr your display modes, and make sure
that X is trying to do something compatible with your monitor.
Also check that /var/log/Xorg.0.log for info that could indicate
an error.

Plus, you can check to see what gnome is doing:
  ps --forest -u newusername -o pid,ppid,args
where "newusername" is your test username that's starting gnome.

Perhaps someone knowledgeable about gnome startup can help
Leon triage this test case?

-Bob Arendt

Hahahahaha! (Maniacal laughter)

I managed to get GDM working with the VESA driver and specifying details about my monitor but I got the same results when logging into GNOME! i.e. my results above were a red herring, the black screen was how GNOME runs on my system.

The reason? My system has been screwed by yum/rpm/Package Manager!

Hahahahaha! (More maniacal laughter)

You see, when I did startx gnome-session ... and entered my credentials for NM, it brought the wireless NIC up. So I thought it's got to be worth running a yum update. But it complained that there was an existing transaction queued, please run yum-complete-transaction. So I did. And it started removing 1300 packages.

So I now have a non-working system!

Hahahahaha! (Okay, enough with the maniacal laughter).

In short Bob, your advice was very helpful and got my system to run as well as it could. I'm certainly giving up for now. At least until the beta...

For the people who do yum/rpm/Package Manager you've got a pretty powerful weapon there, apply for DARPA funding!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]