F12b won't start X on ThinkPad W700

Adam Williamson awilliam at redhat.com
Sun Nov 1 21:22:03 UTC 2009

On Sun, 2009-11-01 at 21:39 +0100, Vedran Miletić wrote:
> On Sun, Nov 1, 2009 at 8:55 PM, Robert G. (Doc) Savage
> <dsavage at peaknet.net> wrote:
> >
> > Adam,
> >
> > To answer your question: No xorg.conf file. Whatever is causing this
> > problem seems to have introduced itself during the F12a -> F12b upgrade.
> > The W700 has a new nvidia chip, and I suppose it's possible its pci code
> > isn't properly detected by the nouveau (?) driver in F12b???
> >
> > I ran into some speed bumps burning a 64-bit DVD. I'm running the media
> > test now. Should have a fresh test install some time this evening. Will
> > let you know in a few hours.
> >
> > --Doc
> >
> >
> Have you tried "forcing" it to use nouveau (by removing nv or by
> explicitely specifying nouveau in xorg.conf)? It would be interesting
> to see what happens.
> Aside from that, can you provide output of lspci -v, to see what
> module is claiming it? Probably nouveau, and that's an explanation why
> nv fails.

It is almost certainly nouveau, there's no real need to check. I need to
know the exact situation in order to figure out whether there's a bug
and where the bug is.

lspci -nn output would be useful. Are you _sure_ there's
no /etc/X11/xorg.conf file ? The only chips that the auto-detect code
should use nv for are very old ones. Unless NVIDIA have started re-using
PCI IDs...

Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org

More information about the fedora-test-list mailing list