VMware Workstation 7 and rawhide

Christopher A. Williams chriswfedora at cawllc.com
Thu Nov 5 15:36:40 UTC 2009

On Mon, 2009-11-02 at 15:06 -0800, Nathan Grennan wrote:
> On 10/30/2009 05:10 PM, Christopher A. Williams wrote:
> > On Tue, 2009-10-27 at 17:25 -0700, Nathan Grennan wrote:
> >> Today I installed VMware Workstation 7 build 203739 x86_64 on my
> >> rawhide system. It runs, but has issues with guests crashing when I try
> >> to move the mouse cursor outside the guest's display area. In a terminal
> >> window I get errors like the one below. The urls below are threads on
> >> VMware's forums talking about the issue. It seems to have been narrowed
> >> down to glibc-2.10.90. I looked into downgrading to 2.10.1, but found
> >> that can't be done without breaking half the system. Like others I tried
> >> downgrading libX11, without success.
> >>
> >>    It get the impression from a little research that I have done that
> >> Fedora 12 is going to be a mess with random applications, because of the
> >> newer glibc. glibc's home page says 2.10.1 is the current stable
> >> release. glibc-2.10.90 seems to be getting lots of fixes as of late.
> >> glibc being such a core package can break almost anything if it isn't
> >> stable. Fedora 12's release is only three weeks away.
> >>
> >> vmware-vmx: xcb_io.c:542: _XRead: Assertion `dpy->xcb->reply_data !=
> >> ((void *)0)' failed.
> >>
> >> http://communities.vmware.com/thread/236673?tstart=45
> >> http://communities.vmware.com/thread/229891?start=15&tstart=0
> >>
> >
> > Don't know if you got a response on this or not, but VMware released the
> > final version of Workstation 7 today.
> >
> > I will try with F12RC on my laptop and let you know what I come up with.
> >
>   I was talking about the final release of VMware Workstation 7.
>   It seems to be more than Workstation using glibc 2.10.1 or not. I 
> tried installing Fedora 11 x86_64 in a chroot, and then installing 
> Workstation in that. It still crashed in the same way. I think the 
> problem relates to Xorg or one of it's libraries running in combination 
> with glibc 2.10.90. The reason I think this is in the chroot everything 
> should have been equivalent to running Workstation on a normal install 
> of Fedora 11. Which I have tested, and does work. But being that Xorg 
> was running outside the chroot, it was using 2.10.90. Workstation still 
> passes information back and forth with Xorg, even when running in the 
> chroot.

Sorry - my bad on the build number. You must have loaded it within hours
of its actual release.

That is interesting. Based on the behavior I have seen, I would tend to
agree with you. I can confirm from my own experience that WS7 runs fine
on F11. It installs just fine on F12 (selinux issues aside), launches
the base program, and even attempts to start a VM, but then fails at the
point you mention.

If it is Xorg, perhaps we'll see this change in the next few days when
F12 actually releases. In any case, it should be a great problem to dig
into further...



"Only two things are infinite,
the universe and human stupidity,
and I'm not sure about the former."

-- Albert Einstein

More information about the fedora-test-list mailing list