F12 RC possible bug when windows pre installed???

Antonio Olivares olivares14031 at yahoo.com
Sun Nov 8 19:00:36 UTC 2009

--- On Sat, 11/7/09, Gianluca Cecchi <gianluca.cecchi at gmail.com> wrote:

> From: Gianluca Cecchi <gianluca.cecchi at gmail.com>
> Subject: F12 RC possible bug when windows pre installed???
> To: "For testers of Fedora Core development releases" <fedora-test-list at redhat.com>
> Date: Saturday, November 7, 2009, 10:00 AM
> Hello,just downloaded boot.iso (170Mb)
> from 
> http://ftp.tudelft.nl/download.fedora.redhat.com/linux/development/x86_64/os/images/boot.iso
> with timestamp 07-Nov-2009 14:13  171M
> My test system has a partition layout that
> comprehends 
> sda1 ntfs with windows XP and set as bootable by
> windows xp itself
> inside the winxp fs  I also have the copy of
> the first 512 bytes of sda4, to boot my F11 partition (with
> grub installed previously in root partition) from boot.ini
> of windows.
> Now I have also sda2 that is
> scratchable.I run the cd where I burnt the
> boot.iso and select sda2 as target partition and to install
> grub on root partition (so sda2)
> This grub setup phase completes, but then I get an error
> about repositories not aligned with my install treee and I
> can only retry (with same failure) or reboot.
> I reboot and I'm not able to start win xp anymore.
> I start the same f12 cd in rescue and notice with fdisk
> that now  my sda has this
> sda1 no bootable flag
> sda2 bootable flag
> so that I remove bootbale flag from sda2 and set bootable
> flag for sda1 and my windows XP starts again and also is
> able again to start my F11 from sda4
> Is this a bug or does it depends on installation not
> finished?
> Anyway I think we have to consider a possible error and the
> bootable flasg should not be removed from sda1.....

I have noticed also, that Fedora install disks whether livecd's or RC candidates also seem to get the /boot/grub/grub.conf file wrong.  The linux partition gets properly setup, but the windows partition is wrong.  ie, the computer has a restore partition and it becomes the default leaving the other partition unbootable.  I solved it via

changing (hd0,0) to (hd0,1) and modifying the name one to windows and the other to rescue partition.  This is a heads up and IMO should be placed in the documentation.  It has happened to me at least 3 times and I apologize in advance for not making a bugzilla(time, work, other excuses, etc), found a workaround instead.  I trashed two windows installations because of this, but in the end I was happy to run Fedora.  

I know that it is *impossible* to setup a system in which all the possibilities are known, but there are some machines/many in fact that hace a restore partition and the installation of grub maps to it instead of the "normal" windows(C:\) partition.  

Thanks for reading this message.




More information about the fedora-test-list mailing list