VMware Player 3 DOES NOT work on Rawhide

Jonathan Kamens jik at kamens.brookline.ma.us
Mon Nov 9 16:39:40 UTC 2009

While I'm glad to hear that VMware Workstation 7 works on Rawhide, I'm sorry
to say that, at least for me, VMware Player 3 does NOT.  I upgraded
everything from Rawhide just yesterday and then installed and tried to run
VMware Player.  It installs cleanly but coredumps on startup.

VMware Server 2 doesn't work either.  The custom modules don't compile
against the current kernel, and while it's possible to hack the module
source to get it to compile, the result appears to be quite unstable.  I
crashed VMware several times and locked up my system once while trying to
get it to work.

Alas, this means there's no way to run VMware virtual machines for free on
F12, at least not until VMware does something to make either VMware Player
or VMware Server work better with it.

Please note that I *did* look for alternatives to VMware before going down
this route.  First, I tried Qemu.  Unfortunately, I can't use KVM with it
because my CPU doesn't support Intel-VT, and apparently the folks who
maintain Qemu for Fedora have decided not to support kqemu, so the
performance of Qemu is positively awful, and in fact it's so slow that the
application that I need to run on Windows (TurboTax) doesn't work.

I tried getting TurboTax to install and run under WINE, a huge time sink
which in the end turned out to be a complete waste of time.

I suppose there's little that can be done by the Fedora developers, except
perhaps to reconsider dropping support for kqemu.  I guess I'm just going to
have to bite the bullet and spend the time and money to set myself up with a
new motherboard and CPU that support KVM so that Qemu will run at a
reasonable speed. (Yes, I consider that preferable to spending money for
VMware Workstation -- I *do* support free software, after all. :-)


More information about the fedora-test-list mailing list