"yum update gcc" runs into libmudflap-devel

Robert P. J. Day rpjday at crashcourse.ca
Tue Nov 10 18:08:13 UTC 2009

On Tue, 10 Nov 2009, Michael Schwendt wrote:

> On Tue, 10 Nov 2009 09:32:12 -0800, Adam wrote:
> > On Tue, 2009-11-10 at 18:03 +0100, Michael Schwendt wrote:
> >
> > > > ...or what weird third-party package may be preventing
> > > > libmudflap-devel from getting updated...
> > >
> > > Conspiracy theories are not helpful. There have been similarily
> > > "weird" packages in the Fedora package collection before, too.
> >
> > um. It's hardly a conspiracy theory, it's a common cause of this
> > kind of problem.
> "Common"? Where do those packages come from? I think your point of
> view is biased and inappropriate. Over the past months, dependency
> issues caused by third party packages have not been anything like a
> hot or regular topic. Much more common have been duplicates,
> interrupted transactions, upgrade path issues, multi-arch
> install/repo configuration bugs, and real packaging mistakes in the
> Fedora package collection.

  against my better judgment, let me expand on the above.  a number of
the people who responded to my "drive by" post are correct -- there
was more i could have done to debug that alleged issue.  but that
fails to address the question i was asking.  should a simple

  # yum update gcc

have worked?

  now, people suggested that there's no way to know what the cause of
the failure was without knowing what was installed, what wasn't
installed, what repos i had active, what 3rd-party packages i'd
already loaded, etc, etc.  and that's entirely correct.  but it misses
the fundamental point:  should that command have worked?

  if it should have, then that's my cue to start doing some research,
and answering some of those questions.  so let's clearly distinguish
between the two stages of resolving this:

1) identify that there *is*, in fact, a problem that should not have
occurred, after which

2) start digging into *why* it occurred, looking for a solution.

  frankly, it's just as embarrassing to post a long-winded,
excruciatingly-detailed post, only to have someone point out, very
concisely, that i did something silly in line 1.  so, i posted the
command i ran, and the subsequent output.  based simply on that
output, is there anything worth following up on?  it's a simple


p.s.  just for fun and stress testing, i ran:

  # yum update

and it's currently at 370/774.  looking good so far.  again, doing
this might not have much value once f12 is out, but it's certainly
giving the upgrade utility a workout.


Robert P. J. Day                               Waterloo, Ontario, CANADA

            Linux Consulting, Training and Kernel Pedantry.

Web page:                                          http://crashcourse.ca
Twitter:                                       http://twitter.com/rpjday

More information about the fedora-test-list mailing list