increasing grub timeout?

Adam Williamson awilliam at
Tue Nov 24 18:24:32 UTC 2009

On Tue, 2009-11-24 at 09:18 -0800, Jesse Keating wrote:

> > For what it's worth, testing that this morning, I held down the shift
> > key after booting and it still just booted with a 0 timeout.  So, I'm
> > not sure that solution is universal. 
> > 
> > (I didn't try tapping other keys, don't ahve a chance right this
> > moment.)

> Odd.  Every physical machine and virt machine I've tried it has worked.
> I suppose if you held it down too early you may have triggered your
> bios' stuck key loop.

On my partner's machine, the BIOS initializes the USB keyboard some time
after boot. So the sequence is power on, wait some seconds while POST
screen is displayed, during this time it prints some message about USB,
only *after* that will any input from the keyboard be recognized. So if
you just hit power and hold down a key, it won't register for any

I imagine there are other systems like that out there, and you wouldn't
notice this if you used a PS/2 keyboard...

Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org

More information about the fedora-test-list mailing list