Getting errormessage on cvs: Permission denied (publickey).

Richard van der Luit zuma at
Thu Jan 8 18:19:02 UTC 2009

Sorry peeps,
dont know if this question belongs here but getting this errormessage
while trying to checkout cvs (roger is my local account here):

Enter passphrase for key '/home/roger/.ssh/id_rsa':     [i did]
Permission denied (publickey).
cvs [checkout aborted]: end of file from server (consult above messages
if any)

while executing:

$ export CVSROOT=:ext:nippur at
$ cvs co -c

do i miss something here? The provided passphrase was correct, tried it
several times, no connection... 

output ssh -v nippur at

$ ssh -v nippur at
OpenSSH_4.5p1, OpenSSL 0.9.8b 04 May 2006
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /home/roger/.ssh/identity type -1
debug1: identity file /home/roger/.ssh/id_rsa type 1
debug1: identity file /home/roger/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '' is known and matches the RSA host
debug1: Found key in /home/roger/.ssh/known_hosts:2
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/roger/.ssh/identity
debug1: Offering public key: /home/roger/.ssh/id_rsa
debug1: Remote: Forced command: /usr/bin/cvs server
debug1: Remote: Port forwarding disabled.
debug1: Remote: X11 forwarding disabled.
debug1: Remote: Agent forwarding disabled.
debug1: Remote: Pty allocation disabled.
debug1: Server accepts key: pkalg ssh-rsa blen 277
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
Enter passphrase for key '/home/roger/.ssh/id_rsa': 
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
Enter passphrase for key '/home/roger/.ssh/id_rsa': 
debug1: Trying private key: /home/roger/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey).

My private key works fine with other progs though....
am i blocked for some reason? (tried to log in when i wasnt authorized
yet, in december)



Fedora-trans-list mailing list
Fedora-trans-list at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Dit berichtdeel is digitaal ondertekend
URL: <>

More information about the Fedora-trans-list mailing list