[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 365111] failed allocation in output stream initialization causes segfault



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=365111


Ulrich Drepper <drepper redhat com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |CLOSED
                 CC|                            |drepper redhat com
    Customer Facing|                            |---
         Resolution|                            |WORKSFORME




--- Comment #6 from Ulrich Drepper <drepper redhat com>  2008-08-03 01:22:25 EDT ---
I see this also with the instructions you provide.  But there must be a problem
with gdb.  Try this instead:

- put a breakpoint at the ALLOC_BUF macro use in filedoalloc.c

- run until breakpoint hit

- disp/i $pc

- use ni until _after_ the mmap call

- now use set $rax=0xffffffffffffffff   (equivalent for other archs, this ix
x86-64)

- c

This works fine, the short buffer is used.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]