[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 223642] unsatisfied dependencies after allowing erase



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: unsatisfied dependencies after allowing erase


https://bugzilla.redhat.com/show_bug.cgi?id=223642





------- Additional Comments From n3npq mac com  2008-07-17 08:05 EST -------

(aside) This is an xorg-x11-filesystem packaging flaw:

     Requires(pre): filesystem >= 2.3.7-1

Clearly the contents of filesystem are needed after xorg-x11-filesystem
is installed. The (pre) marker asserts the filesystem is _ONLY_ needed
while installing, not after being installed, which is obviously false.

There's a similar packaging flaw in libX11:

     Requires(pre): xorg-x11-filesystem >= 0.99.2-3

an assertion that xorg-x11-filesystem is needed _ONLY_ while
installing, not after being installed.

Get the assertions correct and rpm will honor the assertions.






-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]