[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 451770] New: Cannot create bridged network for paravirtualized guest.

Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.


           Summary: Cannot create bridged network for paravirtualized guest.
           Product: Fedora
           Version: 8
          Platform: ia64
        OS/Version: Linux
            Status: NEW
          Severity: high
          Priority: low
         Component: xen
        AssignedTo: xen-maint redhat com
        ReportedBy: sella digital-genesis com
         QAContact: extras-qa fedoraproject org
                CC: berrange redhat com,fedora-triage-
                    list redhat com,sella digital-genesis com

+++ This bug was initially created as a clone of Bug #386151 +++

Description of problem:
I cannot create a bridged network connection using either virt-manager or
virt-install.  Virt-manager does not allow me to specify a shared interface
(paravirtualized guest) - the space contains no choices.  When I try to create
the guest using virt-install, I specify --network briege:eth0 and get hotplug
errors of this type: 
can't add vif1.0 to bridge eth0: Operation not supported

Version-Release number of selected component (if applicable):

How reproducible:
Always happens.

Steps to Reproduce:

1.  virt-install -p -n fed8p -r 1000 -f /var/lib/xen/images/fed8p -s 8 -l
--os-type=linux --os-variant=generic26 --network bridge:eth0
2.  Follow the installation sequence until the network setting step.  Specify
dhcp and the boot will hang (and then return to the network set up question)
Actual results:
Guest installation cannot get past the network set up question.

Expected results:
Normal installation

Additional info:

-- Additional comment from moose quadruped com on 2007-11-15 21:40 EST --
Created an attachment (id=260681)
 --> (https://bugzilla.redhat.com/attachment.cgi?id=260681&action=view)
xend log of failed installation due to network problem

-- Additional comment from moose quadruped com on 2007-11-15 21:50 EST --
Created an attachment (id=260701)
 --> (https://bugzilla.redhat.com/attachment.cgi?id=260701&action=view)
virt-install log of guest create that fails with network problem.

-- Additional comment from moose quadruped com on 2007-11-16 07:52 EST --
I should note that this is the i386 version of Fedora 7 running on x86_64
hardware (a Dell Precision 690).  I see this problem regardless of SELinux
setting (I'
ve tried enforcing, permissive, and disabled - albeit without any reboots
between attempts).

-- Additional comment from moose quadruped com on 2007-11-16 22:30 EST --
Created an attachment (id=262081)
 --> (https://bugzilla.redhat.com/attachment.cgi?id=262081&action=view)
Xend log from rebooted system reveals network bridge errors

I rebooted my machine and examined the xend log.  Please note the errors
indicating failures to create network bridges.	What do I have to do to avoid
these?	Is this a known problem with Fedora 7, a problem with my platform, or
some obscure configuration error?

-- Additional comment from sella digital-genesis com on 2008-03-23 18:18 EST --
I've run into this issue on both Fedora 7 and Fedora 8. In both cases, it only
happens after I update the system with yum. It appears to be an issue with dbus
or how virt-manager works with it.

Using virt-manager to create new bridged Xen virtual machines works fine after a
fresh install. After I use yum to update the system I'm no longer able to create
virtual machines with bridged interfaces. Specifically, in virt-manager on the
"Connect to a Host" screen, the "Shared physical device" option has an empty
drop down for "device".

Below is a fix that worked for me with Fedora 8 (didn't try Fedora 7):

On the updated system, as root, mount the install DVD and change to the
directory containing your original set of RPMs ("Packages" with Fedora 8,
"Fedora" with Fedora 7), then reinstall the old RPMs for dbus, dbus-libs and


# cd /media/disk/Packages
# rpm -Uvh --oldpackage dbus-1.1.2-7.fc8.x86_64.rpm 
dbus-libs-1.1.2-7.fc8.x86_64.rpm dbus-libs-1.1.2-7.fc8.i386.rpm

*NOTE: You may need to specify other packages if RPM complains about dependencies.

This fix is very similar to one mentioned for RHES5.1 here:


There is also mention of the same issue in CentOS-5, which they resolve by
patching /usr/share/virt-manager/virtManager/connection.py. Description and
patch is here:


Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]