[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 446294] incorrect exit from 'ls'



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: incorrect exit from 'ls'


https://bugzilla.redhat.com/show_bug.cgi?id=446294





------- Additional Comments From metcalfegreg qwest net  2008-05-15 04:40 EST -------
(In reply to comment #4)
> I'm changing the product version to rawhide(as the behaviour is still same for
> rawhide and the issue is not so severe(just partially misleading ls
> documentation)). Change happened after release of RHEL-4 but before RHEL-5,
> therefore RHEL-4 returns 1 and RHEL-5 returns 2 for missing dir. Just FYI, this
> is the upstream commit with the change of ls exit code behaviour:
> 
http://git.savannah.gnu.org/gitweb/?p=coreutils.git;a=commitdiff;h=3a208b14048121755eb01377f985372561a4b953

Ondrej, thanks for the Savannah git link and RHEL-4 to -5 info. I have some internal 
things to check, based on that, and you've probably saved me a problem or two. Also 
thanks for confirming on rawhide, and changing Product ID, so I don't have to remember 
to keep this alive in a week or two, when things will likely be a bit crazy, and this might 
have fallen through the cracks. Much appreciated, both cases.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]