[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 249469] [msi, mmconf] Kernel 2.6.22.1-27.fc7 sata drive fails to mount



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: [msi, mmconf] Kernel 2.6.22.1-27.fc7 sata drive fails to mount


https://bugzilla.redhat.com/show_bug.cgi?id=249469





------- Additional Comments From marcosmds terra com br  2008-05-17 01:08 EST -------
Well, I have just installed Fedora 9 and "pci=nomsi" is no more necessary. Now
Fedora 9 sees my SATA HD as expected. I'm sure that's not the correct place to
talk about Fedora 9. But perhaps this little bit is useful. After a clean boot,
Fedora 9 reports there is a kernel problem and offers to notify kernel
developers. Due to this message, I checked dmesg and found this:
------------[ cut here ]------------
WARNING: at drivers/ata/ahci.c:645 ahci_enable_ahci+0x2b/0x2d [ahci]() (Not tainted)
Modules linked in: ahci(+) libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd
ohci_hcd ehci_hcd
Pid: 451, comm: modprobe Not tainted 2.6.25.3-18.fc9.x86_64 #1

Call Trace:
 [<ffffffff81034665>] warn_on_slowpath+0x60/0x91
 [<ffffffff81201011>] ? pci_conf1_read+0xbb/0xc9
 [<ffffffff8120231e>] ? raw_pci_read+0x1a/0x32
 [<ffffffff811adfdf>] ? devres_find+0x8a/0xa7
 [<ffffffff81135028>] ? pcim_iomap_release+0x0/0x3a
 [<ffffffff880a7506>] :ahci:ahci_enable_ahci+0x2b/0x2d
 [<ffffffff880a8686>] :ahci:ahci_init_one+0x18a/0x930
 [<ffffffff810ee84c>] ? sysfs_addrm_finish+0x20/0x205
 [<ffffffff810ee3ce>] ? sysfs_find_dirent+0x1c/0x31
 [<ffffffff8112cb9f>] ? ida_get_new_above+0xf4/0x1a5
 [<ffffffff810ee1f0>] ? sysfs_ilookup_test+0x0/0x14
 [<ffffffff8102afb5>] ? task_rq_lock+0x3d/0x73
 [<ffffffff8113d599>] pci_device_probe+0xc7/0x11e
 [<ffffffff811aba99>] driver_probe_device+0xc0/0x16e
 [<ffffffff811abbda>] __driver_attach+0x93/0xd3
 [<ffffffff811abb47>] ? __driver_attach+0x0/0xd3
 [<ffffffff811ab2b6>] bus_for_each_dev+0x4f/0x89
 [<ffffffff8112d476>] ? kobject_get+0x1a/0x22
 [<ffffffff811ab8e4>] driver_attach+0x1c/0x1e
 [<ffffffff811aab2d>] bus_add_driver+0xb7/0x200
 [<ffffffff811abda3>] driver_register+0x5e/0xde
 [<ffffffff8113d810>] __pci_register_driver+0x53/0x8b
 [<ffffffff880b101e>] :ahci:ahci_init+0x1e/0x20
 [<ffffffff81057747>] sys_init_module+0x193f/0x1a87
 [<ffffffff810a4db8>] ? do_sync_read+0xe7/0x12d
 [<ffffffff810a57fd>] ? vfs_read+0xab/0x154
 [<ffffffff8100bedb>] system_call_after_swapgs+0x7b/0x80

---[ end trace 61a475b3a53e5918 ]---
Up too now it looks just an information since my computer seems to work with no
problem. Using "pci=nomsi" makes no difference.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]