[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 332781] No sound for non-root users



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=332781


Daniel Qarras <dqarras yahoo com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |tmraz redhat com
          Component|ConsoleKit                  |pam




--- Comment #36 from Daniel Qarras <dqarras yahoo com>  2009-04-03 11:46:11 EDT ---
> ConsoleKit thinks that your session is not active, thus, you don't get acls on
> the sound devices (which are set up for the active session). If you do your own
> hand-rolled session, you are responsible for registering with ConsoleKit.

Well the thing is that this has worked for years and years before ConsoleKit
came and there should be no need to introduce these kind of regressions even if
ConsoleKit brings in some additional features.

Anyway, I inspected this "own hand-rolled session" thingy and found the command
ck-xinit-session (but no man page or command line help for it). If put to
~/.xinitrc it does not help. If run from a terminal after GNOME is launched
mpg123 etc work ok.

BUT! When hitting Ctrl+C to quit mpg123 the whole system is shut down! Yes,
this is just insane: I had a root session on another console but when a regular
user innocently just tried to stop his application with Ctrl+C under GNOME, the
whole system went down in flames.

I am changing the component to 'pam' as suggested to see if they could apply
the proposed fix in Comment 17.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]