[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 204448] RPM verify not functional: "file's dependencies has changed since prelinking"



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=204448





--- Comment #10 from Need Real Name <bugzilla kosowsky org>  2009-11-22 01:51:09 EDT ---
OK - I think I figured out part of the problem. It seems that 'prelink' hadn't
run since the system was built so this messed up the verifies. After running
prelink, most (but NOT all) of the pre-link errors and "S.?......" lines have
resolved.

However, even running 'rpm -Va' right after a "full" prelink, I still get a
bunch of residual prelink errors:
    prelink: /usr/lib/libusb-1.0.so.0.0.0: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libusb-1.0.so.0.0.0
    prelink: /usr/lib/libblas.so.3.2.1: at least one of file's dependencies has
 changed since prelinking
    S.?......    /usr/lib/libblas.so.3.2.1
    prelink: /usr/lib/libevent-1.4.so.2.1.3: at least one of file's
dependencies has changed since prelinking
    S.?......    /usr/lib/libevent-1.4.so.2.1.3
    prelink: /usr/lib/libgfortran.so.3.0.0: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libgfortran.so.3.0.0
    prelink: /usr/lib/atlas/libatlas.so.3.0: at least one of file's
dependencies has changed since prelinking
    S.?......    /usr/lib/atlas/libatlas.so.3.0
    prelink: /usr/lib/atlas/libcblas.so.3.0: at least one of file's
dependencies has changed since prelinking
    S.?......    /usr/lib/atlas/libcblas.so.3.0
    prelink: /usr/lib/atlas/libf77blas.so.3.0: at least one of file's
dependencies has changed since prelinking
    S.?......    /usr/lib/atlas/libf77blas.so.3.0
    prelink: /usr/lib/atlas/liblapack.so.3.0: at least one of file's
dependencies has changed since prelinking
    S.?......    /usr/lib/atlas/liblapack.so.3.0
    prelink: /usr/lib/libamd.so.2.2.0: at least one of file's dependencies has
changed since prelinking
    S.?......    /usr/lib/libamd.so.2.2.0
    prelink: /usr/lib/libcamd.so.2.2.0: at least one of file's dependencies has
changed since prelinking
    S.?......    /usr/lib/libcamd.so.2.2.0
    prelink: /usr/lib/libccolamd.so.2.7.1: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libccolamd.so.2.7.1
    prelink: /usr/lib/libcholmod.so.1.7.1: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libcholmod.so.1.7.1
    prelink: /usr/lib/libcolamd.so.2.7.1: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libcolamd.so.2.7.1
    prelink: /usr/lib/libcxsparse.so.2.2.3: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libcxsparse.so.2.2.3
    prelink: /usr/lib/libumfpack.so.5.4.0: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libumfpack.so.5.4.0
    prelink: /usr/lib/libftgl.so.2.1.3: at least one of file's dependencies has
changed since prelinking
    S.?......    /usr/lib/libftgl.so.2.1.3
    prelink: /usr/lib/libqrupdate.so.1.0: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libqrupdate.so.1.0
    prelink: /usr/lib/libarpack.so.2.1: at least one of file's dependencies has
changed since prelinking
    S.?......    /usr/lib/libarpack.so.2.1
    prelink: /usr/lib/libgtkspell.so.0.0.0: at least one of file's dependencies
has changed since prelinking
    S.?......    /usr/lib/libgtkspell.so.0.0.0


I also still don't understand what the difference is between a "?" and a "5" in
the md5sum field.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]