[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 553330] New: OpenOffice cannot Print Directly to custom printer



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.

Summary: OpenOffice cannot Print Directly to custom printer

https://bugzilla.redhat.com/show_bug.cgi?id=553330

           Summary: OpenOffice cannot Print Directly to custom printer
           Product: Red Hat Enterprise Linux 5
           Version: 5.4
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: medium
          Priority: low
         Component: openoffice.org
        AssignedTo: caolanm redhat com
        ReportedBy: djast ecf utoronto ca
         QAContact: desktop-bugs redhat com
                CC: aalam redhat com, jnavrati redhat com,
                    fedora-triage-list redhat com
   Estimated Hours: 0.0
    Classification: Red Hat
          Clone Of: 429897


+++ This bug was initially created as a clone of Bug #429897 +++

Description of problem:


I'm experiencing similar symptoms to those described in Bug #429897 using
openoffice.org-writer2.3.0-6.11.el5_4.1 under RHEL5.

Specifically: under several different circumstances, I'm seeing this:

"From a trace, it appears that OOo is fetching a blank shell command from the
printer info, appending " 2>/dev/null" and executing that.  This of course
doesn't cause anything to be printed."

Some of the circumstances under which this has been observed to occur include:
- using the "Print File Directly" button (as in Bug #429897);
- using "File -> Print" when Desktop Effects are enabled;
- using "File -> Print" on print certain documents originally created with
Microsoft Word; for some reason, the bug seems to happen only the first time
the user tries to print during the Writer session (if Desktop Effects are not
enabled).

Version-Release number of selected component (if applicable):
2.3.0-6.11.el5_4.1

How reproducible:
Always (via "Print File Directly")

Steps to Reproduce:
1. Disable CUPS server
2. echo 'gtk-print-backends = "lpr,file"' >> /etc/gtk-2.0/gtkrc
   (alternatively: echo 'gtk-print-backends = "lpr,file"' >> $HOME/.gtkrc-2.0)
3. oowriter
4. type some characters (or paste a few pages of text)
5. Press the printer icon in the toolbar

Actual results:
If the document is very short, nothing happens (after the "Untitled1 is being
printed on Generic Printer" dialog disappears, which is the "dialogue box
[that] flashes up so quickly it can't be seen" described in Bug #429897).  If
the generated Postscript is large enough to produce a SIGPIPE when the empty
shell command exits, a dialog box with the message "Error while printing"
appears. 
In either case, no printout appears.

Expected results:
A printed document.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]