[fedora-virt] virt-manager/libvirtd beginner question: how to "convert" qemu-kvm image for use by virt-manager

Cole Robinson crobinso at redhat.com
Mon Apr 27 17:46:19 UTC 2009

Tom London wrote:
> I have a pre-existing qemu-kvm VM that I run with the following command:
> qemu-kvm -localtime -vga std -m 512 -usbdevice tablet -name "Windows
> XP" -hda ~/VirtualMachines/raw.img -k en-us
> I've been trying to "convert/adapt" this to be run with virt-manager,
> without success.  Is there a "recipe" I can follow?
> I ran the following 'virt-install' command on a "copy" of the image:
> [root at tlondon ~]# virt-install --name=WinXP --ram=512 --accelerate
> --os-type=windows --os-variant=winxp -v --import
> --file=/home/tbl/VirtualMachines/gold-raw.img --vnc
> Starting install...
> Guest installation complete... restarting guest.
> [root at tlondon ~]#
> But the VM fails to complete booting: I see the BIOS screen, followed
> by the Windows "previous attempt to boot failed" screen, and an
> endless cycling between these 2 screens.
> virt-manager shows the VM running.  I clean up each time by "forcing
> shutdown" and deleting the VM from within virt-manager.
> I can boot the image (~/VirtualMachines/gold-raw.img) after this with
> 'qemu-kvm' without problem.
> I've tried swapping '--sdl' for '--vnc', adding 'noacpi', dropping
> '--accelerate', to no avail.
> Is what I'm trying to do feasible, or is the qemu-kvm image 'polluted'
> with unsupported drivers and or settings?
> Appreciate any help!
> tom

Hmm, can you run 'virsh edit yourvmname' (will launch vi by default),
and in the <features> block, add:


If it isn't already present. Then try starting your VM.

- Cole

More information about the Fedora-virt mailing list