[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Losing mouse focus


I had the same problem and received the following from Daniel Berrange

On Wed, Mar 18, 2009 at 08:53:02AM +0000, Brendan Whelan wrote:

> I am new to using virtualization and, after some effort, I have created > and then cloned a virtual image on a laptop with an Intel P8400 > processor using Fedora 10. > Unfortunately, when I run the cloned image I don't have proper cursor > control, even after pressing ctrl-alt. Any suggestions?
There was a bug in GTK-VNC for mouse grab handling. I've hust pushed an
update to the stable repos so it should show up in a couple of days
You want

As of Fedora 11, the mouse will work perfectly without any grab being



I waited a few days and did a yum update on my Fedora 10 system and the problem went away.

Hope this helps.


Bill Davidsen wrote:
I have asked this on both Fedora and KVM lists, and I get back a mix of "it's you, I don't have the problem" and "mee, too" responses, so sorry if you saw this elsewhere.

I have been running little machines using KVM from command line. Lots of little machines, CentOS, FC9, 10, and now 11. I run them on machine like i6600, e9400, and Athlon dual core, using FC9, FC10, and FC6 with recent kernel and KVM. Since I see the problem on multiple places I assume it isn't unique.

The problem is that I lose mouse (but not keyboard) focus, running in a window or full screen. I will be typing, mail or documentation, and all of a sudden while the keyboard input going where it should, there's another mouse pointer, and it's not bound to the VM I'm using. The VM mouse cursor just sits there...

I don't see any fixes listed anywhere, using "nomodeset" was suggested, but it didn't help. This was mildly annoying when I was testing, now that I'm running many production images it's unproductive. Any thoughts or pointers?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]