[fedora-virt] cannot mount USB disks even after selinux update for Windows VM

Paul Lambert eb30750 at gmail.com
Sun Jul 12 15:35:59 UTC 2009

I have searched the bug list to resolve this problem and after making
the same changes as others still am not able to get external USB disks
to mount to my Windows virt machine.

current versions

1) The first problem encountered was a SELinux matter that updating to
.62 corrected.  There was no virt_use_usb parameter in the version
that was previously installed.  The absence of this SELinux permission
disallowed access to /sbin/ifconig generating a selinux permission

2) Next I received a "broken pipe" error.  I then tried commenting out
the line containing
"nss_initgroups_ignoreusers" in /etc/ldap.conf which was documented in
the bug list and has worked for others.  This did not work for me.

Current status is the shown below from the virt machine log file.

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc -m 768 -s
mp 2 -name Windows-XP-SP3-Home -uuid ee3bc9fe-a724-45b5-b675-11251f5c453f -monit
or pty -pidfile /var/run/libvirt/qemu//Windows-XP-SP3-Home.pid -boot c -drive fi
le=/var/lib/libvirt/images/Windows-XP-SP3-Home.img,if=ide,index=0,boot=on -drive
 file=,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:7e:1c:92,vlan=0,mode
l=virtio -net tap,fd=17,vlan=0 -serial pty -parallel none -usb -usbdevice tablet
 -vnc -usbdevice host:1d6b:0002
char device redirected to /dev/pts/0
char device redirected to /dev/pts/1
husb: open device 2.1
husb: config #1 need -1
husb: 1 interfaces claimed for configuration 1
husb: grabbed usb device 2.1
usb_linux_update_endp_table: Broken pipe
Warning: could not add USB device host:1d6b:0002

More information about the Fedora-virt mailing list