[fedora-virt] Can't use network in guests

Richard W.M. Jones rjones at redhat.com
Tue Jul 28 18:21:40 UTC 2009

On Tue, Jul 28, 2009 at 04:35:43PM +0200, Gianluca Sforna wrote:
> On Tue, Jul 28, 2009 at 4:13 PM, Mark McLoughlin<markmc at redhat.com> wrote:
> >>    <interface type='bridge'>
> >>      <mac address='54:52:00:49:73:9a'/>
> >>      <source bridge='br0'/>
> >>      <target dev='vnet%d'/>
> >
> > Try deleting this line
> I tried removing the line with virsh edit, but restarting the VM with
> virsh start leads to the same error. I double checked and the line
> appeared again, I've no idea how it got there again...

'virsh edit' isn't editing a simple configuration file, that's why.

When the domain is running, it asks libvirt to create an XML
representation of the domain running domain (from libvirtd's internal
data structures), which it edits, then that is parsed back by libvirt
into some internal structures.

When the domain is inactive, ... actually I know it uses a different
path, but I'm not sure what precisely happens with KVM guests, but Dan
will be able to tell us all.

Anyway there is plenty of scope for edits to go strangely.


Richard Jones, Emerging Technologies, Red Hat  http://et.redhat.com/~rjones
virt-df lists disk usage of guests without needing to install any
software inside the virtual machine.  Supports Linux and Windows.

More information about the Fedora-virt mailing list